Bug 1230357 - dnf fails to install older kernel from local files when yum can
Summary: dnf fails to install older kernel from local files when yum can
Keywords:
Status: CLOSED DUPLICATE of bug 1191611
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-10 17:23 UTC by Christopher Beland
Modified: 2015-07-24 12:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-24 12:37:03 UTC


Attachments (Terms of Use)
Zipped copy of debugdata/ from run with --debugsolver (5.59 MB, application/zip)
2015-06-10 17:25 UTC, Christopher Beland
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1191611 None None None Never

Internal Links: 1191611

Description Christopher Beland 2015-06-10 17:23:52 UTC
With these installed, currently running kernel-4.0.4-303:
dnf-1.0.0-1.fc22.noarch
yum-3.4.3-505.fc22.noarch
kernel-4.0.4-303.fc22.x86_64
kernel-core-4.0.3-300.fc22.x86_64
kernel-core-4.0.4-301.fc22.x86_64
kernel-core-4.0.4-303.fc22.x86_64
kernel-debug-devel-4.0.4-303.fc22.x86_64
kernel-headers-4.0.4-303.fc22.x86_64
kernel-modules-4.0.3-300.fc22.x86_64
kernel-modules-4.0.4-301.fc22.x86_64
kernel-modules-4.0.4-303.fc22.x86_64

[beland@localhost ~]$ sudo dnf install --allowerasing ./kernel-4.0.2-300.fc22.x86_64.rpm ./kernel-modules-4.0.2-300.fc22.x86_64.rpm ./kernel-core-4.0.2-300.fc22.x86_64.rpm 
Last metadata expiration check performed 2:24:36 ago on Wed Jun 10 10:55:20 2015.
Error: conflicting requests.
conflicting requests

[beland@localhost ~]$ sudo yum-deprecated install ./kernel-4.0.2-300.fc22.x86_64.rpm ./kernel-modules-4.0.2-300.fc22.x86_64.rpm ./kernel-core-4.0.2-300.fc22.x86_64.rpm 
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Examining ./kernel-4.0.2-300.fc22.x86_64.rpm: kernel-4.0.2-300.fc22.x86_64
Marking ./kernel-4.0.2-300.fc22.x86_64.rpm to be installed
Examining ./kernel-modules-4.0.2-300.fc22.x86_64.rpm: kernel-modules-4.0.2-300.fc22.x86_64
Marking ./kernel-modules-4.0.2-300.fc22.x86_64.rpm to be installed
Marking ./kernel-modules-4.0.2-300.fc22.x86_64.rpm to be installed
Marking ./kernel-modules-4.0.2-300.fc22.x86_64.rpm to be installed
Examining ./kernel-core-4.0.2-300.fc22.x86_64.rpm: kernel-core-4.0.2-300.fc22.x86_64
Marking ./kernel-core-4.0.2-300.fc22.x86_64.rpm to be installed
Marking ./kernel-core-4.0.2-300.fc22.x86_64.rpm to be installed
Marking ./kernel-core-4.0.2-300.fc22.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:4.0.2-300.fc22 will be installed
---> Package kernel-core.x86_64 0:4.0.2-300.fc22 will be installed
---> Package kernel-modules.x86_64 0:4.0.2-300.fc22 will be installed
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel-core.x86_64 0:4.0.3-300.fc22 will be erased
---> Package kernel-modules.x86_64 0:4.0.3-300.fc22 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================
 Package                      Arch                 Version                        Repository                                           Size
============================================================================================================================================
Installing:
 kernel                       x86_64               4.0.2-300.fc22                 /kernel-4.0.2-300.fc22.x86_64                       0.0  
 kernel-core                  x86_64               4.0.2-300.fc22                 /kernel-core-4.0.2-300.fc22.x86_64                   41 M
 kernel-modules               x86_64               4.0.2-300.fc22                 /kernel-modules-4.0.2-300.fc22.x86_64                17 M
Removing:
 kernel-core                  x86_64               4.0.3-300.fc22                 installed                                            41 M
 kernel-modules               x86_64               4.0.3-300.fc22                 installed                                            17 M

Transaction Summary
============================================================================================================================================
Install  3 Packages
Remove   2 Packages

and that works just fine.

Comment 1 Christopher Beland 2015-06-10 17:25:33 UTC
Created attachment 1037369 [details]
Zipped copy of debugdata/ from run with --debugsolver

Comment 2 Honza Silhan 2015-07-24 12:37:03 UTC

*** This bug has been marked as a duplicate of bug 1191611 ***


Note You need to log in before you can comment on or make changes to this bug.