Bug 123042 - glibc-2.3.3-24 doesn't compile
Summary: glibc-2.3.3-24 doesn't compile
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-11 18:46 UTC by Steve Grubb
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.3.3-31
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 10:11:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch that fixes the problem (480 bytes, patch)
2004-05-11 18:48 UTC, Steve Grubb
no flags Details | Diff

Description Steve Grubb 2004-05-11 18:46:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
Somewhere between glibc-2.3.3-18 & glibc-2.3.3-24 a change occurred
that causes glibc not to successfully compile anymore. I get these errors:

../sysdeps/unix/sysv/linux/llseek.c:46: warning: `used' attribute ignored
gconv_stubs.c:83: conflicting types for `__gconv_close_transform'
../iconv/gconv_int.h:232: previous declaration of
`__gconv_close_transform'
gconv_stubs.c:85: conflicting types for `__gconv_close'
../iconv/gconv_int.h:172: previous declaration of `__gconv_close'

This is only 2, there are many.

Version-Release number of selected component (if applicable):
glibc-2.3.3-24

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/SPEC/glibc.spec

    

Actual Results:  make[2]: ***
[/home/build/working/BUILD/glibc-2.3.3-200405031851/build-i386-linux/c_stubs/gconv_stubs.o]
Error 1
make[1]: *** [c_stubs/others] Error 2
make: *** [all] Error 2
error: Bad exit status from /home/build/working/tmp/rpm-tmp.31687 (%build)
    Bad exit status from /home/build/working/tmp/rpm-tmp.31687 (%build)


Expected Results:  A message indicating that it wrote the rpm.

Additional info:

I will attach a patch that fixes the problem.

Comment 1 Steve Grubb 2004-05-11 18:48:19 UTC
Created attachment 100159 [details]
A patch that fixes the problem

Please apply

Comment 2 Jakub Jelinek 2004-05-11 19:15:43 UTC
Works just fine for me.  What GCC are you using?

Comment 3 Steve Grubb 2004-05-11 20:41:13 UTC
I am using gcc-3.2.2-5. 

The problem is that gconv_stubs.c is including an internal header,
gconv_int.h, that has prototypes that are different than the stubs.
All that the stubs file needs is gconv.h in order to declare a couple
of structures. glibc-2.3.3-18 compiles fine.

Comment 4 Jakub Jelinek 2004-05-25 10:11:17 UTC
This will show up in glibc-2.3.3-31.


Note You need to log in before you can comment on or make changes to this bug.