Bug 123043 - sed-4.0.8-4 fails to compile
sed-4.0.8-4 fails to compile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-11 15:01 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 06:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-05-11 15:01:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The sed package fails to build stating:

================================
6 of 57 tests failed
Please report to bonzini@gnu.org
================================

They are: 

FAIL: lvl-030323-2
[lvl-030323-2] Error 139

FAIL: lvl-030323-4
[lvl-030323-4] Error 1

FAIL: lvl-030323-5
[lvl-030323-5] Error 1

FAIL: lvl-030323-6
[lvl-030323-6] Error 139

XFAIL: lvl-030824
cmp ./lvl-030824.good lvl-030824.out
./lvl-030824.good lvl-030824.out differ: byte 17, line 2

FAIL: lvl-030912
cmp ./lvl-030912.good lvl-030912.out
./lvl-030912.good lvl-030912.out differ: byte 9, line 3

FAIL: space
cmp ./space.good space.out
./space.good space.out differ: byte 6, line 1



Version-Release number of selected component (if applicable):
sed-4.0.8-4

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/SPEC/sed.spec
    

Actual Results:  rpmbuild fails to produce a sed package.

Expected Results:  a messsage stating where it wrote the sed package.

Additional info:
Comment 1 Jakub Jelinek 2004-05-11 15:10:52 EDT
Certainly works for me just fine.
What glibc you have installed?  sed relies on recent glibc to pass make check
(otherwise a bunch of regex bugfixes are missing).
Comment 2 Steve Grubb 2004-05-11 16:32:56 EDT
I am using glibc-2.3.2-27.9.7 on my build host.

If building it requires glibc-2.3.3, could you add a BuildRequires
glibc >= 2.3.3 ? My build host will work out the dependencies and
compile it properly if that tag is there. Thanks.
Comment 3 Jakub Jelinek 2004-05-25 06:04:33 EDT
Added to sed-4.0.9-1 in rawhide.
Comment 4 Robert Scheck 2004-05-26 15:56:23 EDT
Steve, you should disable the patch 2 and you should remove the 
"--without-included-regex" at sed-4.0.8-(2|3|4) then it would build 
fine at Red Hat Linux 9.

I'm NOT able to reproduce the rebuilding problem using glibc-2.3.2-
27.9.7 (from Red Hat Linux 9) and sed-4.0.9-1. Jakub, please remove 
that strange dependency with the next sed rebuild. Thank you very
much :)

Note You need to log in before you can comment on or make changes to this bug.