Bug 1230501 - BuildRequires on gcc-c++ not glibc-headers.
Summary: BuildRequires on gcc-c++ not glibc-headers.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: squid
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luboš Uhliarik ✈
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1217762
Blocks: 1230505
TreeView+ depends on / blocked
 
Reported: 2015-06-11 04:25 UTC by Carlos O'Donell
Modified: 2015-11-01 02:46 UTC (History)
5 users (show)

Fixed In Version: squid-3.5.9-7.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-01 02:46:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Carlos O'Donell 2015-06-11 04:25:26 UTC
Please replace the BuildRequires: glibc-headers with BuildRequires: gcc-c++. The new Fedora packaging guidelines require you define all the things you need in the buildroot to build [1].

Given that this package has C/C++ code it should BuildRequires: gcc-c++, and that is sufficient to bring in all of the required core C/C++ libraries and headers to compile C/C++ code.

The reason I'm asking is because glibc-headers may or may not be removed in the future and it isn't sufficient to guarantee the package builds.

[1] https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRequires_2

Comment 1 Jan Kurik 2015-07-15 14:01:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23

Comment 2 Luboš Uhliarik ✈ 2015-09-11 11:39:03 UTC
Change prepared, but impossible to build new squid.rpm due to this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1217762

Comment 3 Fedora Update System 2015-09-25 10:57:56 UTC
squid-3.4.13-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-05490fc42d

Comment 4 Fedora Update System 2015-09-25 11:04:40 UTC
squid-3.5.9-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1781d1322a

Comment 5 Fedora Update System 2015-09-27 00:55:38 UTC
squid-3.5.9-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update squid'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1781d1322a

Comment 6 Fedora Update System 2015-10-06 14:01:01 UTC
squid-3.5.9-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8d643c4d18

Comment 7 Fedora Update System 2015-10-07 16:27:58 UTC
squid-3.5.9-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update squid'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8d643c4d18

Comment 8 Fedora Update System 2015-11-01 02:45:48 UTC
squid-3.5.9-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.