Bug 1230550 - [abrt] qemu-system-x86: __memcmp_sse4_1(): qemu-system-x86_64 killed by SIGSEGV
Summary: [abrt] qemu-system-x86: __memcmp_sse4_1(): qemu-system-x86_64 killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:13c6cd94b9dc9b41ca64699c744...
: 1233053 (view as bug list)
Depends On: 1163047
Blocks: 1230808
TreeView+ depends on / blocked
 
Reported: 2015-06-11 07:07 UTC by Gerd Hoffmann
Modified: 2015-12-04 16:45 UTC (History)
18 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1163047
: 1230808 (view as bug list)
Environment:
Last Closed: 2015-12-04 16:45:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Gerd Hoffmann 2015-06-11 07:07:33 UTC
+++ This bug was initially created as a clone of Bug #1163047 +++

Description of problem:
I was running the virtual machine (in gnome-boxes or maybe in virt-manager in qemu usermode) with stable debian (with lxde) and I changed resolution in it (since it was a little larger than my display). Then it crashed.

I tried changing video from QXL to VGA (in virt manager), it did not help (I am not sure which crash is this, one with QXL or with VGA).

Also: before that, the graphics in VM was doing strange things - mouse cursor was leaving trails, some windows did not refresh, some animations left "parts behind" (that is: if there was animation of a red thing moving across screen, it would leave red stripes behind it).

Version-Release number of selected component:
qemu-system-x86-2.1.2-6.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/bin/qemu-system-x86_64 -machine accel=kvm -name debian7 -S -machine pc-i440fx-2.1,accel=kvm,usb=off -cpu Westmere -m 1536 -realtime mlock=off -smp 4,sockets=1,cores=2,threads=2 -uuid 573d08d5-0198-46d9-a425-1c1045aa80aa -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/stevko/.config/libvirt/qemu/lib/debian7.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-shutdown -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot order=c,menu=on,strict=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -device usb-ccid,id=ccid0 -drive file=/home/stevko/.local/share/gnome-boxes/images/debian7,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -drive 'file=/home/stevko/Stiahnut\xc3\xa9/debian-7.7.0-amd64-netinst.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw' -device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=22,id=hostnet0 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:42:92:ec,bus=pci.0,addr=0x3 -chardev spicevmc,id=charsmartcard0,name=smartcard -device ccid-card-passthru,chardev=charsmartcard0,id=smartcard0,bus=ccid0.0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing,image-compression=off,seamless-migration=on -device VGA,id=video0,bus=pci.0,addr=0x2 -device AC97,id=sound0,bus=pci.0,addr=0x4 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -msg timestamp=on
crash_function: __memcmp_sse4_1
executable:     /usr/bin/qemu-system-x86_64
kernel:         3.17.2-300.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __memcmp_sse4_1 at ../sysdeps/x86_64/multiarch/memcmp-sse4.S:69
 #1 qemu_spice_create_update at ui/spice-display.c:228
 #2 qemu_spice_display_refresh at ui/spice-display.c:464
 #3 dpy_refresh at ui/console.c:1431
 #4 gui_update at ui/console.c:195
 #5 timerlist_run_timers at qemu-timer.c:491
 #6 qemu_clock_run_timers at qemu-timer.c:502
 #7 qemu_clock_run_all_timers at qemu-timer.c:608
 #8 main_loop_wait at main-loop.c:490
 #9 main_loop at vl.c:2010

Potential duplicate: bug 872889

--- Additional comment from Štefan Gurský on 2014-11-12 11:05:18 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:19 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:21 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:23 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:25 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:26 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:27 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:30 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:31 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:33 CET ---



--- Additional comment from Štefan Gurský on 2014-11-12 11:05:34 CET ---



--- Additional comment from Cole Robinson on 2015-06-10 16:39:04 CEST ---

I think this upstream patch will fix it:

https://lists.nongnu.org/archive/html/qemu-devel/2015-06/msg02764.html

Comment 2 FuXiangChun 2015-06-19 06:01:28 UTC
Gerd,
QE filed a similar bug before. please help to confirm whether they are the same the problems.

Bug 1233053 - Segmentation fault when boot guest with spice

Comment 3 Gerd Hoffmann 2015-06-19 06:58:26 UTC
(In reply to FuXiangChun from comment #2)
> Gerd,
> QE filed a similar bug before. please help to confirm whether they are the
> same the problems.
> 
> Bug 1233053 - Segmentation fault when boot guest with spice

High chance to be a duplicate.

Comment 4 Miroslav Rezanina 2015-06-19 11:09:33 UTC
Fix included in qemu-kvm-rhev-2.3.0-3.el7

Comment 5 Gerd Hoffmann 2015-06-23 07:52:20 UTC
*** Bug 1233053 has been marked as a duplicate of this bug. ***

Comment 6 Shaolong Hu 2015-07-01 05:43:08 UTC
Reproduce on qemu-kvm-rhev-2.3.0-2.el7.x86_64:

#gdb --args /usr/libexec/qemu-kvm -m 2G -smp 4 -boot menu=on -drive file=/home/win2012-64r2-virtio.qcow2,if=none,id=img -device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=0x8 -device scsi-hd,drive=img,id=img-disk -monitor stdio -spice port=5932,disable-ticketing -qmp tcp::8886,server,nowait -vga std

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff0addce9 in __memcmp_sse4_1 () from /lib64/libc.so.6
(gdb) bt
#0  0x00007ffff0addce9 in __memcmp_sse4_1 () from /lib64/libc.so.6
#1  0x00005555557b9275 in qemu_spice_display_refresh ()
#2  0x00005555557b0c42 in gui_update ()
#3  0x00005555557df139 in timerlist_run_timers ()
#4  0x00005555557df2b0 in qemu_clock_run_all_timers ()
#5  0x00005555557de17c in main_loop_wait ()
#6  0x00005555555e11ee in main ()


Verified on qemu-kvm-rhev-2.3.0-4.el7.x86_64:

# /usr/libexec/qemu-kvm -m 2G -smp 4 -boot menu=on -drive file=/home/win2012-64r2-virtio.qcow2,if=none,id=img -device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=0x8 -device scsi-hd,drive=img,id=img-disk -monitor stdio -spice port=5932,disable-ticketing -qmp tcp::8886,server,nowait -vga std
QEMU 2.3.0 monitor - type 'help' for more information
(qemu) 
(qemu) 
(qemu)

Comment 10 errata-xmlrpc 2015-12-04 16:45:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.