Bug 1230627 - Should give more friendly info when the ova file is broken
Summary: Should give more friendly info when the ova file is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-11 09:12 UTC by wanghui
Modified: 2016-03-09 14:30 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:30:02 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
screenshot of ova file broken (1.79 MB, image/jpeg)
2015-06-11 09:12 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 42237 master MERGED Show a friendly dialog if the download is bad Never

Description wanghui 2015-06-11 09:12:31 UTC
Created attachment 1037565 [details]
screenshot of ova file broken

Description of problem:
It should provide more friendly info when the downloaded ova file is broken.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.7-20150609.0
ovirt-node-plugin-hosted-engine-0.2.0-15.0.el6ev.noarch
rhev-hypervisor7-7.1-20150609.0
ovirt-node-plugin-hosted-engine-0.2.0-15.0.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a broken ova file.
   # dd if=/dev/zero of=test.ova bs=1M count=20
2. File the OVA URL for download in TUI.
3. Check the prompt infos.

Actual results:
1. It will give the prompt info directly in the TUI page by mess up the original page.

Expected results:
1. It should give more friendly way to provide the info.

Additional info:

Comment 1 Fabian Deutsch 2015-06-11 09:45:49 UTC
It is a visual problem happening when a random file is used as the appliance image, instead of an OVA.

Comment 2 wanghui 2015-11-24 05:59:03 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1.el7ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch

Test steps:
1. Create a broken ova file.
   # dd if=/dev/zero of=test.ova bs=1M count=20
2. File the OVA URL for download in TUI.
3. Check the prompt infos.

Test result:
After step3, it prompts like follows.

│Checking pre-conditions ...                                                                                                                                                                 │
│(1/1) Writing Hosted Engine Config File                                                                                                                                                     │
│                                                                                                                                                                                            │
│An error occurred while applying the changes:                                                                                                                                               │
│Downloaded image is neither an OVA nor an ISO, can't use it 

So this issue is fixed in ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch. Change the status to verified.

Comment 4 errata-xmlrpc 2016-03-09 14:30:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.