Bug 123073 - rhn_package_manager getting Internal Server Error uploading src.rpm
rhn_package_manager getting Internal Server Error uploading src.rpm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks: rhn360sat
  Show dependency treegraph
 
Reported: 2004-05-11 20:47 EDT by Jack Neely
Modified: 2007-04-18 13:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:31:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of rhn_package-manager run (3.56 KB, text/plain)
2004-05-11 20:48 EDT, Jack Neely
no flags Details

  None (edit)
Description Jack Neely 2004-05-11 20:47:28 EDT
Description of problem:
I have recently installed a new RHN Proxy attempting to move from a
temporary machine to new hardware that was bought for the purpose. 
(Dell 1750).  Install went smoothly.  I did not regenerate the SSL
certs and installed the cert RPMs from the old Proxy.  The machine
seems to be working properly.

Next I used rhn_package_manager to upload all my custom binary and
source RPMs for my channels -- for the sole reason of getting them
back on my Proxy to be served out.  Binary RPMs went fine, but the
source packages refuse to upload and to move back in place in
/var/up2date/packages.  Gives me Internal Server Error.  Full log with
-v is attached.

Version-Release number of selected component (if applicable):
rhns-proxy-package-manager-3.2.0-2

How reproducible:
Every time.

Steps to Reproduce:
I'm running the command:
# rhn_package_manager --source -v -c realmlinux-ws3 -d SRPMS/
Type in my OA user ID and password.
Comment 1 Jack Neely 2004-05-11 20:48:32 EDT
Created attachment 100169 [details]
Log of rhn_package-manager run
Comment 2 Todd Warner 2004-05-12 00:33:49 EDT
punting to misa, our package manager man.
Comment 3 Mihai Ibanescu 2004-06-03 12:25:22 EDT
Should be fixed in the latest version of the code.
Comment 4 Todd Warner 2004-06-03 12:35:11 EDT
TEST PLAN:
----------
o test all funcionality of rhn_package_manager, it is way overdue,
  to include pushing RPMs and SRPMs, individually and enmasse.
Comment 5 Fanny Augustin 2004-06-25 15:31:03 EDT
I tested the tool with:
rhn_package_manager -v --dir /var/spool/up2date

This directory does not contain any RPMs per say, but the error
message (traceback) I received did not contain any information about
why the tool is failing.  I think this error message should be
cleaner, in other words, it should let the customer knows that they
are no packages (rpm) to manage in the given directory.  Below is the
traceback I received:

Connecting to https://rhnblade4.perf.redhat.com/XP
Uploading /var/spool/up2date/redhat-advanced-server-i386.20040625001752
Traceback (innermost last):
  File "/usr/bin/rhn_package_manager", line 29, in ?
    rhn_package_manager.main()
  File "/var/www/rhns/PackageManager/rhn_package_manager.py", line
103, in main
    upload.uploadHeaders()
  File "/var/www/rhns/PackageManager/uploadLib.py", line 307, in
uploadHeaders
    verbose=self.options.verbose, nosig=self.options.nosig)
  File "/var/www/rhns/PackageManager/uploadLib.py", line 429, in
_processBatch
    nosig=nosig)
  File "/var/www/rhns/PackageManager/uploadLib.py", line 387, in
_processFile
    h = get_header(None, f.fileno(), source)
  File "/var/www/rhns/PackageManager/uploadLib.py", line 578, in
get_header
    h = rhn_rpm.get_package_header(filename=file, fd=fildes)
  File "/var/www/rhns/PackageManager/rhn_rpm.py", line 112, in
get_package_header
    raise InvalidPackageError
PackageManager.rhn_rpm.InvalidPackageError

Comment 6 Greg DeKoenigsberg 2004-07-01 11:15:32 EDT
Fanny,

Let's file this error-handling bug as a separate bug that blocks
rhn350sat instead.  If the functionality for pushing RPMs and SRPMs
works as advertised if the RPMs/SRPMs are actually present, this fix
is acceptable to me.
Comment 7 Fanny Augustin 2004-07-07 16:59:10 EDT
Not all functionalities are working as expected.  I created a software
channel on the sat.  I received the error message below while trying
to list the packages in the channel, even though I was the one who
created the channel:

Sat: https://farm03.rhndev.redhat.com/
user/passwd: farm03/dog8code 
channel: channel-test

[root@slag temp]# rhn_package_manager --list -c channel-test
Channels: channel-test
Red Hat Network username: farm03
Red Hat Network password:
Connecting to http://farm03.rhndev.redhat.com/XP
 
Error Message:
    You are not allowed to manage channel channel-test
Error Class Code: 32
Error Class Info: Channel error
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
 
[root@slag temp]#
Comment 8 Greg DeKoenigsberg 2004-07-19 08:41:53 EDT
Moving to rhn350sat for clarification.
Comment 9 Mihai Ibanescu 2004-07-20 17:33:07 EDT
Internal server error fixed.
Comment 10 Mihai Ibanescu 2004-07-20 17:33:35 EDT
Fanny, if the above error still happens, please pull me in because I
don't understand why it says that.
Comment 11 Fanny Augustin 2004-08-05 14:49:11 EDT
proxy test
Comment 12 Fanny Augustin 2004-08-18 17:12:29 EDT
aligning against rhn360sat for full testing...  Taw has tested this
partially on rhn350sat.
Comment 13 Todd Warner 2004-10-21 12:34:02 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 14 Fanny Augustin 2004-11-20 15:52:49 EST
Works find with the exception of this observation:

I had 4 packages in the channel:

  	rhn-applet-actions-2.0.13-2.noarch   	 
	rhncfg-3.1.6-12.noarch 	
	samba-common-3.0.0-14.3E.i386 	
	samba-common-3.0.7-1.3E:0.i386 	

When I: rhn_package_manager --list -c channel-test...  I got:

['rhn-applet-actions', '2.0.13', '2', '', 'noarch', 'channel-test']
['rhncfg', '3.1.6', '12', '', 'noarch', 'channel-test']
['samba-common', '3.0.7', '1.3E', '0', 'i386', 'channel-test']

Please notice that one of the samba packages is listed instead of the
two packages...  Is this behavior expected or this is a bug?

Comment 15 Clay Murphy 2004-12-02 19:16:41 EST
no docs
Comment 16 Todd Warner 2005-03-22 13:31:30 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.