Bug 1230957 - pulseaudio 6.0 breaks 5.1 network sound configuration (fixed in upstream)
Summary: pulseaudio 6.0 breaks 5.1 network sound configuration (fixed in upstream)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-11 21:13 UTC by rh
Modified: 2015-06-24 16:01 UTC (History)
4 users (show)

Fixed In Version: pulseaudio-6.0-4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-21 00:04:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 90125 0 None None None Never

Description rh 2015-06-11 21:13:48 UTC
Description of problem:

In pulseaudio 6.0, 5.1 sound transmission over the native pulseaudio protocol doesn't work. For details, see https://bugs.freedesktop.org/show_bug.cgi?id=90125

Version-Release number of selected component (if applicable):
Reproducible with 6.0-fc22 and 6.0-fc23
Fixed since 7b8e8cd3883e081a6e3f2d8ed307524801438e04 in pulseaudio

How reproducible:
Always


Would it be possible to publish an update to Fedora updates containing this patch? It breaks network compatibility, and upgrade compatibility (worked with FC21 as far as I know)

Comment 1 Rex Dieter 2015-06-12 03:22:31 UTC
Thanks, will take a look.

Comment 2 Rex Dieter 2015-06-12 03:27:02 UTC
fyi, f21 was updated to pulseaudio-6.0 too, see bug #1206764

Comment 3 Rex Dieter 2015-06-12 03:27:48 UTC
err, make that bug #1192384

Comment 4 Fedora Update System 2015-06-12 04:10:26 UTC
pulseaudio-6.0-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/pulseaudio-6.0-4.fc22

Comment 5 Fedora Update System 2015-06-12 04:11:21 UTC
pulseaudio-6.0-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pulseaudio-6.0-4.fc21

Comment 6 Fedora Update System 2015-06-14 17:24:00 UTC
Package pulseaudio-6.0-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-6.0-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9922/pulseaudio-6.0-4.fc22
then log in and leave karma (feedback).

Comment 7 rh 2015-06-15 07:20:25 UTC
Works fine, thanks!

Comment 8 Fedora Update System 2015-06-21 00:04:36 UTC
pulseaudio-6.0-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-06-24 16:01:07 UTC
pulseaudio-6.0-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.