Bug 1230975 - [rfe] configurable parallel downloads (like yum's max_connections)
[rfe] configurable parallel downloads (like yum's max_connections)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-11 18:54 EDT by Jargon Scott
Modified: 2015-08-10 22:08 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-1.0.2-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 22:08:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jargon Scott 2015-06-11 18:54:15 EDT
Description of problem:

Yum supports a "max_connections" parameter, which allows the user to tune the maximum number of simultaneous downloads.

Although DNF supports parallel downloads, I see no means by which the user may *change* the maximum number of concurrent downloads.

Such a feature is desirable, for example, on flaky or unreliable network links.  In these cases, it's useful to set yum's max_connections=1 to maximize the number of packages that have been downloaded completely and cached before the link goes down.

Version-Release number of selected component (if applicable):

librepo-1.7.13-1.fc22.x86_64
dnf-1.0.0-1.fc22.noarch

How reproducible: Always (this is a feature request).

Steps to Reproduce:
1. dnf install foo

Actual results:

Progress meter indicates that two packages are being downloaded simultaneously.

Expected results:

Upon setting a dnf configuration parameter, the progress meter should confirm that 1 (or 3 or ... ) packages are being downloaded at a time.

Additional info:
Comment 2 Fedora Update System 2015-07-22 04:25:22 EDT
dnf-1.0.2-2.fc22,hawkey-0.5.9-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-1.0.2-2.fc22,hawkey-0.5.9-2.fc22
Comment 3 Jargon Scott 2015-07-24 21:10:05 EDT
Thank you very much!

I can confirm that this works for me when setting max_parallel_downloads=1 in /etc/dnf/dnf.conf .

Positive feedback added to the update listed in comment #2 .
Comment 4 Fedora Update System 2015-07-31 22:28:31 EDT
Package dnf-1.0.2-3.fc22, hawkey-0.5.9-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-1.0.2-3.fc22 hawkey-0.5.9-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12577/dnf-1.0.2-3.fc22,hawkey-0.5.9-3.fc22
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-08-10 22:08:28 EDT
dnf-1.0.2-3.fc22, hawkey-0.5.9-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.