Bug 1230977 - FTBFS: po4a fails to build in rawhide due to failing tests
Summary: FTBFS: po4a fails to build in rawhide due to failing tests
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: po4a
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1220189
TreeView+ depends on / blocked
 
Reported: 2015-06-11 23:06 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2015-06-17 07:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-17 07:56:38 UTC
Type: Bug


Attachments (Terms of Use)
Build log against Perl 5.22 (259.71 KB, text/plain)
2015-06-12 14:33 UTC, Jitka Plesnikova
no flags Details

Description Dominik 'Rathann' Mierzejewski 2015-06-11 23:06:09 UTC
Description of problem:
po4a failed to rebuild in current rawhide buildroot due to failing tests.

Version-Release number of selected component (if applicable):
po4a-0.45-5.fc23

How reproducible:
Always

Steps to Reproduce:
1. build current git master (eecf76ed5f1fbfc7a13aef1d286f2382dcac073b)

Actual results:
Testsuite fails.

Expected results:
Tests should pass and package should be built.

Additional info:
http://koji.fedoraproject.org/koji/buildinfo?buildID=643397

Comment 1 Dominik 'Rathann' Mierzejewski 2015-06-11 23:07:22 UTC
Blocks mkvtoolnix update (mkvtoolnix build-depends on po4a).

Comment 2 Jitka Plesnikova 2015-06-12 14:33:47 UTC
Created attachment 1038088 [details]
Build log against Perl 5.22

Comment 3 Ralf Corsepius 2015-06-17 07:44:15 UTC
AFAIS, the cause is perl-5.22 issuing a couple of warnings, which confuse the po4a's testsuite.

I am going to apply a couple of hacks consisting of 3 patches, which let the testsuite succeed again. However, I would expect po4a to have further similar compatibility issues at other places these patches do not address.

FWIW: po4a-0.46 isn't much better. Upstream seems to have addressed one of the problems my patches address, but seem to have introduced another one.


Note You need to log in before you can comment on or make changes to this bug.