Bug 123098 - coreutils missing build requirements
coreutils missing build requirements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 10:33 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.2.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-17 12:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-05-12 10:33:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The coreutils package will not compile without autoconf being at
version  2.58 or higher and automake being at version 1.8 or higher.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-7

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb /usr/src/redhat/SPEC/coreutils.spec
    

Actual Results:  
+ autoconf --force
configure.ac:48: error: Autoconf version 2.58 or higher is required
aclocal.m4:1238: jm_MACROS is expanded from...
configure.ac:48: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
error: Bad exit status from /home/build/working/tmp/rpm-tmp.48423 (%build)


Expected Results:  A message indicating where it wrote the rpm.

Additional info:

The patch to correct the dependencies:

--- working/coreutils/coreutils.spec    2004-04-20 13:35:41.000000000
-0400
+++ /opt/specs/coreutils.spec   2004-05-03 17:52:14.000000000 -0400
@@ -55,6 +55,7 @@
 BuildRequires: gettext libtermcap-devel
 %{?!nopam:BuildRequires: pam-devel}
 BuildRequires: texinfo >= 4.3
+BuildRequires: autoconf >= 2.58 automake >= 1.8
 Prereq:                /sbin/install-info
 %{?!nopam:Requires: pam >= 0.66-12}
 Prereq: grep, findutils
Comment 1 Tim Waugh 2004-05-12 10:38:06 EDT
Thanks.  Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.