Bug 123106 - /proc/kallsyms is missing (kernel 2.6.5-1.358)
Summary: /proc/kallsyms is missing (kernel 2.6.5-1.358)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-12 15:15 UTC by Janus N. Tøndering
Modified: 2015-01-04 22:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 06:27:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Janus N. Tøndering 2004-05-12 15:15:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I just figured out that the /proc/ksyms file is no more (compiling a
module) and that the (acc. to pages found by google) file's now called
/proc/kallsysm. The problem is that there is no such file on my system.

How reproducible:
Always

Steps to Reproduce:
* compile a module, or
* ls /proc/kallsyms

Comment 1 Arjan van de Ven 2004-05-21 21:01:20 UTC
eh what is proc/kallsyms needed for ???


Comment 2 Janus N. Tøndering 2004-05-30 13:04:13 UTC
From http://www.desktop-linux.net/vmware.htm I got this:
"Replace all occurrences of /proc/ksyms with /proc/kallsyms in
/usr/bin/vmware-config.pl."

So, I assumed that it was needed.


Comment 3 Alexander Sandler 2004-09-19 16:58:55 UTC
Arjan, I encountered the same problem with 2.6.5-1.358. I checked 
with 2.6.8-1.521 - same story - /proc/kallsyms not there!

Apparently, noone calls kallsyms_init() (kernel/kallsyms.c), so 
appending:

#ifdef CONFIG_KALLSYMS
__initcall(kallsyms_init);
#endif

to the end of kernel/kallsyms.c does the trick.

Sasha.

Comment 4 Arjan van de Ven 2004-09-19 18:42:34 UTC
again.. what needs it ?

Comment 5 Alexander Sandler 2004-09-19 21:29:38 UTC
In Fedora Core 2 /proc/kallsyms missing - this file lists all kernel
symbols. It might be usefull when working on kernel module or, as
original poster did, installing Fedora Core 2 on VMWare virtual machine.
As I found, problem relies in kernel. All Fedora Core 2 kernels
released so far, has this problem. Finally, fix I proposed based on
Linuses kernel 2.6.8.1 (the latest one so far).

Sasha.

Comment 6 Timur Tabi 2004-11-22 15:48:22 UTC
This bug is a real problem for me.  I need to have /proc/kallsyms.  It
serves two purposes:

1) If a driver can't load because it complains about an unknown
symbol, I can grep kallsyms to see if the symbol is really defined.   

2) Our driver compiles with several different 2.4 and 2.6 versions.  I
use kallsyms to determine which symbols are publically available, and
if a certain symbol is not found, then a warning message is displayed.

Comment 7 Dave Jones 2004-11-27 20:21:54 UTC
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?


Comment 8 Timur Tabi 2004-12-01 16:23:07 UTC
Yes, it is.

Comment 9 Dave Jones 2005-01-25 06:27:42 UTC
current kernels should have this fixed.



Note You need to log in before you can comment on or make changes to this bug.