Bug 1231151 - 'Reclaim Policy' and 'Message' can't show up correctly when using 'oc describe persistentvolumes'
Summary: 'Reclaim Policy' and 'Message' can't show up correctly when using 'oc describ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-12 09:35 UTC by xjia
Modified: 2017-03-08 18:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:29:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description xjia 2015-06-12 09:35:30 UTC
Description of problem:
After creating a persistent volume, check the persistent volume information. 'Reclaim Policy' and 'Message' can't show up correctly


Version-Release number of selected component (if applicable):
oc v0.6.0.1-38-g0e02a6b
kubernetes v0.17.1-804-g496be63


How reproducible:
always

Steps to Reproduce:
1. Create a persistent volume
persistent-volume.json:
{
  "apiVersion": "v1",
  "kind": "PersistentVolume",
  "metadata": {
    "name": "pv0001"
  },
  "spec": {
    "capacity": {
        "storage": "5Gi"
        },
    "accessModes": [ "ReadWriteMany" ],
    "nfs": {
        "path": "/var/export/vol1",
        "server": "master.cluster.local"
    }
  }
}

[root@master beta4]# oc create -f persistent-volume.json
persistentvolumes/pv0001

2. execute 'oc describe persistentvolumes/pv0001'

Actual results:
[root@master beta4]# oc describe persistentvolumes/pv0001
Name:                pv0001
Labels:                <none>
Status:                Available
Claim:                
Reclaim Policy:        %!d(api.PersistentVolumeReclaimPolicy=Retain)
Message:        %!d(string=)



Expected results:
'Reclaim Policy' and 'Message' should show up correctly.


Additional info:

Comment 3 Fabiano Franz 2016-07-04 19:19:09 UTC
Fixed in master.

Comment 4 Xingxing Xia 2016-07-07 08:26:37 UTC
Tested with oc v3.3.0.2, per steps in comment 0. Now the result is:
$ oc describe persistentvolumes/pv0001 --config=vm2/admin.kubeconfig
Name:		pv0001
Labels:		<none>
Status:		Failed
Claim:		xxia-proj/mypvc
Reclaim Policy:	Retain
Access Modes:	RWO
Capacity:	5Gi
Message:	Recycling error: Pod was active on the node longer than specified deadline
Source:
    Type:	NFS (an NFS mount that lasts the lifetime of a pod)
    Server:	<nfs server>
    Path:	/invalid/path
    ReadOnly:	false

'Reclaim Policy' and 'Message' display well.

Comment 6 errata-xmlrpc 2016-09-27 09:29:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.