Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1231162

Summary: pkcon repo-disable disabled repo return 0 should return 5
Product: Red Hat Enterprise Linux 7 Reporter: Marek Stana <mstana>
Component: PackageKitAssignee: Richard Hughes <rhughes>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.2CC: lkolacek, mstana, tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: PackageKit-1.0.7-1.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-11-19 09:18:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Marek Stana 2015-06-12 10:09:24 UTC
Description of problem:
When you try disable disabled repo with pkcon the expected return value is 5 ( means nothing useful was done ), the pkcon return 0 (everything ok).

Version-Release number of selected component (if applicable):
PackageKit-1.0.4-1.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. pkcon repo-list - find some repo which is disabled or disable one
2. disable disabled repo with command pkcon repo-disable "name of repo"
3. use echo $? to get return value of pkcon repo-disable command

Actual results:
return value is 0

Expected results:
return value 5 - as documentation says when 'Nothing useful was done.'

Additional info:

Comment 2 Marek Stana 2015-06-25 10:55:11 UTC
Hi,

this bug is also the same for pkcon repo-enable.

thanks
Marekkk

Comment 3 Richard Hughes 2015-07-08 15:14:26 UTC
I don't think this is super important; to return the correct return code we have to either get the old value and set the new one if it's different (race) or return an error if setting the same value; I certainly don't think returning an error is the most helpful thing to do here. If you think it's an error setting the same enabled state as before then I guess I can change the code to do that. Thanks.

Comment 4 Tomas Pelka 2015-07-10 11:33:24 UTC
(In reply to Richard Hughes from comment #3)
> I don't think this is super important; to return the correct return code we
> have to either get the old value and set the new one if it's different
> (race) or return an error if setting the same value; I certainly don't think
> returning an error is the most helpful thing to do here. If you think it's
> an error setting the same enabled state as before then I guess I can change
> the code to do that. Thanks.

I believe we should do what is written in man pages. As I hope this change is really simple please change the ret code to 5.

Thanks Ritchard
-Tom

Comment 5 Richard Hughes 2015-07-13 08:09:51 UTC
Pushed upstream:

commit 1fb98fffa9adad5e8392365a4761453007e9b3e1
Author: Richard Hughes <richard>
Date:   Mon Jul 13 09:08:24 2015 +0100

    Return the correct error code if nothing was done for repo-enable
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1231162

:100644 100644 8608259... 7fcfdff... M  backends/hif/pk-backend-hif.c
:100755 100755 fc8d3c7... 5e0c978... M  backends/yum/yumBackend.py
:100644 100644 a3c3b3e... 203458e... M  client/pk-console.c

Comment 8 errata-xmlrpc 2015-11-19 09:18:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2139.html