Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When you try disable disabled repo with pkcon the expected return value is 5 ( means nothing useful was done ), the pkcon return 0 (everything ok).
Version-Release number of selected component (if applicable):
PackageKit-1.0.4-1.el7.x86_64
How reproducible:
100%
Steps to Reproduce:
1. pkcon repo-list - find some repo which is disabled or disable one
2. disable disabled repo with command pkcon repo-disable "name of repo"
3. use echo $? to get return value of pkcon repo-disable command
Actual results:
return value is 0
Expected results:
return value 5 - as documentation says when 'Nothing useful was done.'
Additional info:
I don't think this is super important; to return the correct return code we have to either get the old value and set the new one if it's different (race) or return an error if setting the same value; I certainly don't think returning an error is the most helpful thing to do here. If you think it's an error setting the same enabled state as before then I guess I can change the code to do that. Thanks.
(In reply to Richard Hughes from comment #3)
> I don't think this is super important; to return the correct return code we
> have to either get the old value and set the new one if it's different
> (race) or return an error if setting the same value; I certainly don't think
> returning an error is the most helpful thing to do here. If you think it's
> an error setting the same enabled state as before then I guess I can change
> the code to do that. Thanks.
I believe we should do what is written in man pages. As I hope this change is really simple please change the ret code to 5.
Thanks Ritchard
-Tom
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHEA-2015-2139.html