Bug 1231197 - Snapshot daemon failed to run on newly created dist-rep volume with uss enabled
Summary: Snapshot daemon failed to run on newly created dist-rep volume with uss enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On: 1230635
Blocks: 1232883
TreeView+ depends on / blocked
 
Reported: 2015-06-12 11:26 UTC by Avra Sengupta
Modified: 2016-06-16 13:10 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1230635
: 1232883 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:10:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-15 09:46:41 UTC
REVIEW: http://review.gluster.org/11227 (glusterd/uss/snapshot: Intialise snapdsvc after volfiles are created) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-06-15 10:39:19 UTC
REVIEW: http://review.gluster.org/11227 (glusterd/uss/snapshot: Intialise snapdsvc after volfiles are created) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-06-22 08:45:07 UTC
COMMIT: http://review.gluster.org/11227 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 2b9efc920762ad93575a44ae41450f78ecdb0d9e
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Fri Jun 12 17:13:05 2015 +0530

    glusterd/uss/snapshot: Intialise snapdsvc after volfiles are created
    
    snapd svc should be initialised only after all
    relevant volfiles and directories are created.
    
    Change-Id: I96770cfc0b350599cd60ff74f5ecec08145c3105
    BUG: 1231197
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11227
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 15:22:10 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Niels de Vos 2016-06-16 13:10:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.