Bug 1231205 - [geo-rep]: rsync should be made dependent package for geo-replication
Summary: [geo-rep]: rsync should be made dependent package for geo-replication
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1223636 1230607 1231213
TreeView+ depends on / blocked
 
Reported: 2015-06-12 11:42 UTC by Aravinda VK
Modified: 2016-06-16 13:11 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1230607
: 1231213 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:11:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-06-12 11:42:24 UTC
+++ This bug was initially created as a clone of Bug #1230607 +++

Description of problem:
=======================

With the installation of RHEL7.1 (Maipo) (3.10.0-229.el7.x86_64), rsync package is not installed by-default. geo-rep is dependent on rsync package for syncing and hence fails with exception as:


[2015-06-11 14:17:55.360109] E [syncdutils(/rhs/brick1/b1):247:log_raise_exception] <top>: execution of "rsync" failed with ENOENT (No such file or directory)
[2015-06-11 14:17:55.361197] I [syncdutils(/rhs/brick1/b1):220:finalize] <top>: exiting.
[2015-06-11 14:17:55.371893] I [repce(agent):92:service_loop] RepceServer: terminating on reaching EOF.
[2015-06-11 14:17:55.372690] I [syncdutils(agent):220:finalize] <top>: exiting.
[2015-06-11 14:17:55.821278] I [monitor(monitor):282:monitor] Monitor: worker(/rhs/brick1/b1) died in startup phase
[2015-06-11 14:17:56.17366] I [master(/rhs/brick2/b2):1084:crawl] _GMaster: slave's time: (1434012471, 0)
[2015-06-11 14:17:56.361943] E [syncdutils(/rhs/brick2/b2):247:log_raise_exception] <top>: execution of "rsync" failed with ENOENT (No such file or directory)
[2015-06-11 14:17:56.362849] I [syncdutils(/rhs/brick2/b2):220:finalize] <top>: exiting.
[2015-06-11 14:17:56.374238] I [repce(agent):92:service_loop] RepceServer: terminating on reaching EOF.
[2015-06-11 14:17:56.374922] I [syncdutils(agent):220:finalize] <top>: exiting.
[2015-06-11 14:17:56.822371] I [monitor(monitor):282:monitor] Monitor: worker(/rhs/brick2/b2) died in startup phase
[2015-06-11 14:18:06.105169] I [monitor(monitor):221:monitor] Monitor: ------------------------------------------------------------
[2015-06-11 14:18:06.105815] I [monitor(monitor):222:monitor] Monitor: starting gsyncd worker
[2015-06-11 14:18:06.287671] I [changelogagent(agent):75:__init__] ChangelogAgent: Agent listining...
[2015-06-11 14:18:06.288149] I [gsyncd(/rhs/brick1/b1):649:main_i] <top>: syncing: gluster://localhost:master -> ssh://root@rhsqe-vm04.lab.eng.blr.redhat.com:gluster://localhost:slave
[2015-06-11 14:18:07.80266] I [monitor(monitor):221:monitor] Monitor: ------------------------------------------------------------
[2015-06-11 14:18:07.80811] I [monitor(monitor):222:monitor] Monitor: starting gsyncd worker



[root@rhsqe-vm01 ~]# rpm -qa | grep rsync
[root@rhsqe-vm01 ~]# yum search rsync
Loaded plugins: product-id, subscription-manager
============================================================================================== N/S matched: rsync ==============================================================================================
libguestfs-rsync.x86_64 : rsync support for libguestfs
rsync-debuginfo.x86_64 : Debug information for package rsync
rsync.x86_64 : A program for synchronizing files over a network

  Name and summary matches only, use "search all" for everything.
[root@rhsqe-vm01 ~]#

Comment 1 Anand Avati 2015-06-12 11:54:30 UTC
REVIEW: http://review.gluster.org/11201 (spec/geo-rep: Add rsync as dependency for georeplication rpm) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Nagaprasad Sathyanarayana 2015-10-25 15:02:37 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 3 Niels de Vos 2016-06-16 13:11:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.