Bug 1231214 - Include subscription-manager setup in the overcloud by default
Summary: Include subscription-manager setup in the overcloud by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ga
: Director
Assignee: John Trowbridge
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
: 1240378 (view as bug list)
Depends On: 1235000
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-12 12:02 UTC by Mike Burns
Modified: 2015-08-05 13:53 UTC (History)
8 users (show)

Fixed In Version: python-rdomanager-oscplugin-0.0.8-42.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 237487 None None None Never
Gerrithub.io 237542 None None None Never
Gerrithub.io 240831 None None None Never
OpenStack gerrit 197111 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Mike Burns 2015-06-12 12:02:18 UTC
Description of problem:
This may end up being a RHEL OSP only change.

Currently, to enable subscription-manager in the overcloud nodes, it's a manual "copy this file from X to Y".  This should be done automatically in the director

Comment 3 John Trowbridge 2015-06-29 12:24:57 UTC
Patch posted upstream: https://review.gerrithub.io/#/c/237542

The minimum CLI args are added to be able to register to the customer portal or satellite using an activation key.

A couple notes about using this for customer portal registration:

1. The undercloud neutron network needs to have a nameserver configured that can resolve subscription.rhn.redhat.com. (This is not the case by default)

2. We need to apply a patch similar to this one[1] to the rhel-registration script in T-H-T[2]. (Satellite registration is not affected by this issue)


[1] https://github.com/openstack/diskimage-builder/commit/6856d96f03ca7e5a796e5e266c745be28a8dda0b

[2] https://github.com/openstack/tripleo-heat-templates/blob/master/extraconfig/post_deploy/rhel-registration/scripts/rhel-registration

Comment 4 John Trowbridge 2015-06-30 14:35:31 UTC
I posted a patch to T-H-T upstream for portal registration issue: https://review.openstack.org/#/c/197111/

Comment 5 Mike Burns 2015-07-01 15:56:40 UTC
adding https://review.gerrithub.io/#/c/237487/ as a dependency for error handling.

Comment 6 Mike Burns 2015-07-06 18:58:27 UTC
*** Bug 1240378 has been marked as a duplicate of this bug. ***

Comment 7 Mike Burns 2015-07-09 21:01:10 UTC
patch was missing a " -- dropping back to assigned to fix it.

Comment 10 jliberma@redhat.com 2015-07-14 00:47:10 UTC
Mike Burns, John Trowbridge -- does the 07-10.1 puddle include this fix?

python-rdomanager-oscplugin-0.0.8-32.el7ost.noarch

I can test with a sat server if needed.

thanks, jacob

Comment 11 Alexander Chuzhoy 2015-07-21 19:20:07 UTC
Verified: FailedQA


Environment:
instack-undercloud-2.1.2-21.el7ost.noarch


openstack overcloud deploy --plan `openstack management plan list 2>/dev/null|awk '/overcloud/ {print $2}'` --control-scale 1  --compute-scale 2  --ceph-storage-scale 1 --block-storage-scale 0 --swift-storage-scale 0 -e /home/stack/network-environment.yaml --rhel-reg --reg-method portal --reg-org [ID]  --reg-activation-key '[key]'

Results in ERROR: openstack 'NoneType' object has no attribute 'endswith'

Comment 12 John Trowbridge 2015-07-21 19:30:53 UTC
This commit is the root cause:

https://github.com/rdo-management/python-rdomanager-oscplugin/commit/50562410370e2059b98b0ce24f852cd2708a1d55

This makes RHEL registration only work when not using Tuskar. There is no need for that restriction.

Comment 14 John Trowbridge 2015-07-21 19:40:15 UTC
Upstream fix

https://review.gerrithub.io/240831

Comment 16 Alexander Chuzhoy 2015-07-29 17:53:25 UTC
Verified:

Environment:
instack-undercloud-2.1.2-22.el7ost.noarch
python-rdomanager-oscplugin-0.0.8-43.el7ost.noarch

Deployed with:

openstack overcloud deploy --plan `openstack management plan list 2>/dev/null|awk '/overcloud/ {print $2}'` --control-scale 1  --compute-scale 2  --ceph-storage-scale 1 --block-storage-scale 0 --swift-storage-scale 0 -e /home/stack/network-environment.yaml --rhel-reg --reg-method portal --reg-org [ID]  --reg-activation-key '[key]'


Running "subscription-manager repos" on the deployed controller outputs a list of repos.
Running "subscription-manager status":

+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current

Comment 18 errata-xmlrpc 2015-08-05 13:53:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.