Bug 123127 - Installer changes partition info but does not update grub.conf
Installer changes partition info but does not update grub.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 15:16 EDT by Cody Taylor
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 02:51:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cody Taylor 2004-05-12 15:16:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040421

Description of problem:
This is the partition info I chose during install and part of the
grub.conf Fedora created during install.

/dev/hdc
	/dev/hdc1	ntfs
	/dev/hdc2	/boot
	/dev/hdc3	/
  /dev/hdc4
	/dev/hdc5	/home
	/dev/hdc6	swap

title Fedora Core-up (2.4.22-1.2115.nptl)
        root (hd0,1)
        kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/
root=/dev/hdc3 hda=id
e-scsi nofirewire nousb
        initrd /initrd-2.4.22-1.2115.nptl.img


Apparently Fedora prefers to have / on hdc5 so it forced a change but
it did not update grub.conf.  My partition info shows that Fedora
forced / to be on hdc5 but the original grub.conf shows root= the
partition I chose.  After the install my grub.conf had
"root=/dev/hdc3" but df or rdev shows / as being on hdc5.  If you add
another boot option for say a new kernel in grub you must point root
towards /dev/hdc5 or you will get a kernel panic.  You will get a
kernel panic with the original kernel and boot options in grub if you
comment out the initrd line as well.




Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Notice: I am using one hard drive in an Intel PC and it is set to hdc
because of the controller I am using.

1. install windows or something else on hdc1 so it will not be used by
Fedora 
2. minimal install of Fedora Core 1, and manually configure your
partitions during install
3. try to set the following partitions:
/dev/hdc
	/dev/hdc1	ntfs
	/dev/hdc2	/boot
	/dev/hdc3	/
  /dev/hdc4
	/dev/hdc5	/home
	/dev/hdc6	swap
4. once the install is complete run the rdev or df command to check
your root partition, Fedora forced / to be on /dev/hdc5 instead of the
partition you chose
5. cat your grub.conf file and you will notice the root entry is set
to the partition you chose, /dev/hdc3, instead of the partition Fedora
forced, /dev/hdc5
6. if you comment out the initrd entry or the ramdisk, you will get a
kernel panic because the root entry in grub is wrong

Actual Results:  Your grub.conf file will be set up incorrectly and
you will get a kernel panic.

Expected Results:  If Fedora is going to force partitions during
install then it should update your grub.conf file at the same time.

Additional info:

The real problem with this bug is the end user thinks they have / set
to partition /dev/hdc3.  This can cause allot of confusion.  The first
thing I did after install was download and compile a different kernel.
 I had chose to put / on hdc3 and my grub.conf file showed
root=/dev/hdc3, so naturally I used the same root entry for my new
kernel and this caused a kernel panic because Fedora put / on hdc5 but
didn't update my grub.conf.
Comment 1 Jeremy Katz 2004-05-12 15:44:00 EDT
Was there a /boot partition that you didn't reformat involved here? 
I'm having a difficult time following the sequence of events.  The
installer on writing a new boot loader config isn't ever going to
write more than one root= stanza.
Comment 2 Cody Taylor 2004-05-12 15:55:27 EDT
There was not a previous /boot partition.
I installed XP on a new hard drive in a new PC.
Next I installed a minimal load of Fedora Core 1.
During install I told / to be on hdc3.
Fedora changed / to hdc5.
After install rdev shows / on hdc5.
My grub.conf file only shows one root= entry and it is set to
"root=/dev/hdc3"
Comment 3 Jeremy Katz 2004-05-12 16:12:54 EDT
If you create partitions in anaconda, then you don't ever specify what
the partition number is (it's largely irrelevant).  And what
filesystem did you use such that root got set to an explicit device
instead of LABEL=/?
Comment 4 Cody Taylor 2004-05-12 16:36:25 EDT
I created the partitions in the order that resuletd in / being on
hdc3.  I used ext3 for the filesystem.
Fedora changed / from hdc3 to hdc5 but left hdc3 in the grub.conf

title Fedora Core-up (2.4.22-1.2115.nptl)
        root (hd0,1)
        kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/
root=/dev/hdc3 hda=id
e-scsi nofirewire nousb
        initrd /initrd-2.4.22-1.2115.nptl.img
Comment 5 Cody Taylor 2004-05-13 02:50:58 EDT
I did a fresh install of FC1 again and I could not duplicate the 
bug.  Apparently I didn't notice when Fedora changed / from hdc3 to 
hdc5.  During the install I must have passed grub the wrong 
root=/dev/hdc3 option in the advanced boot options.  I can't remember 
doing that but it's the only reasonable answer because like you 
posted earlier, anaconda would not put two root= options in my 
grub.conf.  Sorry for wasting your time.  In the future I will take 
the time to duplicate a possible bug before I submit it.  -Cody

Note You need to log in before you can comment on or make changes to this bug.