Bug 123128 - IBM T23 Laptop causes X server failure and safe mode
IBM T23 Laptop causes X server failure and safe mode
Status: CLOSED DUPLICATE of bug 120858
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 15:39 EDT by Niels Kristian Jensen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Kristian Jensen 2004-05-12 15:39:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
I see the following error message upon starting X (even as root):

X server version data
60700000

(asks for the output of two commands), included below:

[root@K5FA root]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "dk", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "dk", "", ""
[root@K5FA root]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [dk]
 model = pc105
 overrideSettings = false
 options = []
[root@K5FA root]#


I would like to add, that RH9 didn't fint the video resolution. But I
remember that I could use "Generic Laptop display at 1400x1050" -
which worked fine.


Version-Release number of selected component (if applicable):
X server version data: 60700000

How reproducible:
Always

Steps to Reproduce:
1. Try to let Anaconda guess the video resolution (no luck)
2. Select Generic LCD 1400x1050 in system-config-display
3. Restart X
    

Actual Results:  I got a 640x480 window. The video card seems to be
correctly detected, but the monitor is not.

If I run system-config-display with --noui, I get:

ddcprobe returned bogus values



Expected Results:  I would like to use the full resolution of the TFT
display fittet on the IBM T23

Additional info:
Comment 1 Niels Kristian Jensen 2004-05-12 16:56:09 EDT
Oops, I forgot the main error-message, displayed shortly after
entering root as user and pw:

Error activating XKB configuration
Comment 2 Mike A. Harris 2004-05-13 02:35:21 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.