This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 123133 - kernel boot partition check hangs on extra harddisk
kernel boot partition check hangs on extra harddisk
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 16:16 EDT by W. Bertels
Modified: 2007-04-18 13:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 09:28:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Bertels 2004-05-12 16:16:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
After adding an extra disk to an RH 8.0 system the disk will not
get through the partition check at boot. Otherwise the system works 
OK.

system P166, 96 MB, hda 8GB, hdb cdrom, hdc 120 GB works OK.

Tried to add extra hdd harddisk (120 GB), tried just about all:
- Western Digital (slave setting, or cable detect).
- Bios detects the disks and they can be accessed from DOS.
- Bootloader Grub + RH 8.1 Kernel will just hang on partition check.
- Tried different bios settings (autodetect, manual, different 
geometry sizes)
- Even tried the disk alone as master on the cable and as slave on 
the other interface as hdb instead of the cdrom
- Tried an other disk Samsung... same problems

I'm just stuck, the machine will work with a hdd=noprobe, but with no 
access to the disk. Even putting in the hdd=cil,heads,sectors will 
not work.

Kinda desparate...

Willem-Egmond Bertels

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot
2. hangs
3.
    

Additional info:
Comment 1 Dave Jones 2004-05-13 09:28:03 EDT
this product end-of-lifed last december, and hence will recieve no
further updates.
Comment 2 W. Bertels 2004-05-28 04:51:48 EDT
The bug is solved after upgrading to Red Hat 9

Willem-Egmond Bertels

Note You need to log in before you can comment on or make changes to this bug.