Bug 123134 - Under SELinux grubby should create /boor/grub/grub.conf- as boot_runtime_t
Under SELinux grubby should create /boor/grub/grub.conf- as boot_runtime_t
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
Ben Levenson
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 16:22 EDT by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 09:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-05-12 16:22:36 EDT
By default, the new grub.conf the grubby creates ends up being marked
as boot_t, instead of the boot_runtime_t that it is supposed to be.
Comment 1 Jeremy Katz 2004-05-12 16:27:35 EDT
Guess that grubby's going to need policy too :/

Should be something simple, though... just need file auto
transitioning from boot_t -> boot_runtime_t
Comment 2 Daniel Walsh 2004-12-01 09:10:41 EST
We are now just allowing it to run with boot_t so this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.