Bug 123143 - Takes many minutes to shut down eth0 and loopback
Takes many minutes to shut down eth0 and loopback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 18:40 EDT by Kam Leo
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 13:41:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'ps ax' (5.90 KB, text/plain)
2004-05-12 18:44 EDT, Kam Leo
no flags Details

  None (edit)
Description Kam Leo 2004-05-12 18:40:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6) Gecko/20040124

Description of problem:
After upgrading from FC1 to FC2 Test 3 the shutdown/reboot process is
taking much longer to complete.  Specifically it is taking minutes to
shut down eth0 and loopback.  I inserted a date commands into
/etc/init.d/syslog and /etc/init.d/network and got the following
results when shutting down:

   LEVEL 5 SHUTDOWN
00:55:27.811662000  Shutting down kernel logger
00:55:29.151874000    kernel logger down
00:55:29.197130000  Shutting down system logger
00:55:39.751460000    system logger down
00:55:45.365522000  Removed /var/lock/subsys/syslog
00:56:38.073459000  Shutting down interface eth0
00:57:57.468175000    interface eth0 down
00:57:57.478978000  Shutting down loopback interface
00:58:46.692743000    loopback interface down
00:58:46.719086000  Removed /var/lock/subsys/network

  SHUTTING DOWN FROM RUN LEVEL 3
11:42:34.592952000  Shutting down kernel logger
11:42:35.864684000    kernel logger down
11:42:35.890611000  Shutting down system logger
11:42:42.710079000    system logger down
11:42:42.732724000  Removed /var/lock/subsys/syslog
11:43:51.504382000  Shutting down interface eth0
11:46:23.878438000    interface eth0 down
11:46:23.892524000  Shutting down loopback interface
11:47:29.198935000    loopback interface down
11:47:29.232347000  Removed /var/lock/subsys/network

NOTE:  Please assign problem to proper component. I assigned this to
initscripts only because it's the driver for shutdown.

Version-Release number of selected component (if applicable):
initscripts.i386 0:7.53-1

How reproducible:
Always

Steps to Reproduce:
1. From Gnome menu select "Logout"
2. Select either "Shutdown" or "Restart the computer"
3. Click "OK"
    

Actual Results:  Interface eth0 and loopback shutdown takes minutes to
complete.

Expected Results:  Shutting down of eth0 and loopback takes 5-10
seconds each to complete.

Additional info:
Comment 1 Kam Leo 2004-05-12 18:44:10 EDT
Created attachment 100202 [details]
'ps ax' 

Dump of processes at run level 5
Comment 2 Barry K. Nathan 2004-07-15 00:22:44 EDT
I think I've seen this too (or something similar anyway), on FC 2
final, intermittently. Unfortunately I no longer have the hardware on
which I experienced this problem. It always seemed to happen with
PCMCIA or CardBus cards -- and yanking the card of the socket when it
slowed down made the shutdown proceed at normal speed.
Comment 3 Dave Jones 2004-12-08 01:44:02 EST
any better with the 2.6.9 update ?
Comment 4 Kam Leo 2004-12-08 13:39:52 EST
There has been improvement with the newer kernel update. My system now shutsdown
within a reasonable amount of time.

Note You need to log in before you can comment on or make changes to this bug.