Bug 123146 - Consider leaving Mozilla a 32-bit app
Consider leaving Mozilla a 32-bit app
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 19:17 EDT by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 08:44:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2004-05-12 19:17:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
Browsing the web today unfortunately requires a lot of plugins, some
of which are closed source only.

Thus, it might be worthwhile to leave Mozilla a 32-bit application so
that it can use i386 plugins instead of requiring x86-64 plugins,
since a lot of these, e.g. Shockwave Flash, are not yet available for
x86-64.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try finding plugins for x86-64.
    

Additional info:

The i386 RPM of Mozilla works fine on x86-64, assuming the necessary
i386 support libraries are installed as well.
Comment 1 John Thacker 2006-10-29 08:44:04 EST
mozilla (on FC5) and firefox (on FC5 and FC6) are currently installed by default
in both the i386 and x86-64 versions.  It is impossible to currently install
just the i386 version, because certain other applications depend on the
rendering engine.  After xulrunner becomes stable enough to be included, it will
become possible to have the browser completely separate and only have, e.g., the
i386 version installed if a user wishes.  (Of course, that will apply to firefox
instead of mozilla in the future.)

Note You need to log in before you can comment on or make changes to this bug.