Bug 123154 - Nautilus crashes in gnome-vfs2 at startup
Nautilus crashes in gnome-vfs2 at startup
Status: CLOSED DUPLICATE of bug 122662
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 03:00 EDT by Alan Hamilton
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab that causes crash (1013 bytes, text/plain)
2004-05-13 03:01 EDT, Alan Hamilton
no flags Details
fstab that does not cause crash (697 bytes, text/plain)
2004-05-13 03:02 EDT, Alan Hamilton
no flags Details
Stack trace (13.22 KB, text/plain)
2004-05-13 03:03 EDT, Alan Hamilton
no flags Details

  None (edit)
Description Alan Hamilton 2004-05-13 03:00:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
At GUI startup, the taskbar appears at the bottom, but the desktop
stays  black and a 'The Application "nautilus" has quit unexpectedly.'
dialog appears.

Version-Release number of selected component (if applicable):
2.6.0-7

How reproducible:
Always

Steps to Reproduce:
1.  Type startx at command line


    

Actual Results:  Error dialog appears.

Expected Results:  Desktop should start up.

Additional info:

The bug appears to be heap corruption that somehow related to
/etc/fstab.  I have a USB flash card reader that I removed to see if
it was the cause.  Nautilus started successfully after this.  I
discovered that the contents of fstab were causing it.  If I remove
the entries related to the flash reader from fstab (with the reader
still attatched) it works.   Or if I replace the /dev/fd0 line with
one of the flash reader lines it works.

I tried reinstalling FC2 test 3, and it still occurs.  The stack trace
is different, but it's still crashing in a "free" function.
Comment 1 Alan Hamilton 2004-05-13 03:01:27 EDT
Created attachment 100205 [details]
fstab that causes crash
Comment 2 Alan Hamilton 2004-05-13 03:02:14 EDT
Created attachment 100206 [details]
fstab that does not cause crash
Comment 3 Alan Hamilton 2004-05-13 03:03:19 EDT
Created attachment 100207 [details]
Stack trace
Comment 4 Alan Hamilton 2004-05-19 23:13:38 EDT
Just a note to say that this still happens in FC2 Final.
Comment 5 Alan Hamilton 2004-05-27 19:08:07 EDT

*** This bug has been marked as a duplicate of 122662 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.