Bug 1231572 - dnf repoquery --duplicated report is different than package-cleanup --dupes
dnf repoquery --duplicated report is different than package-cleanup --dupes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On: 1243005
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-14 16:41 EDT by Peter Bieringer
Modified: 2015-11-30 18:24 EST (History)
10 users (show)

See Also:
Fixed In Version: dnf-1.1.4-1.fc23 dnf-1.1.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 18:24:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2015-06-14 16:41:58 EDT
Description of problem:
output of duplicate checks is different between yum and dnf

Version-Release number of selected component (if applicable):
dnf-1.0.0-1.fc22.noarch
yum-3.4.3-505.fc22.noarch


How reproducible:
always


Steps to Reproduce:
# LC_ALL=C package-cleanup --dupes

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.


Loaded plugins: fastestmirror, langpacks

(nothing more)


# LC_ALL=C dnf repoquery --duplicated
Last metadata expiration check performed 2:00:09 ago on Sun Jun 14 20:40:51 2015.
kernel-core-0:4.0.4-301.fc22.x86_64
kernel-core-0:4.0.4-303.fc22.x86_64
kernel-devel-0:4.0.4-301.fc22.x86_64
kernel-devel-0:4.0.4-303.fc22.x86_64
kernel-modules-0:4.0.4-301.fc22.x86_64
kernel-modules-0:4.0.4-303.fc22.x86_64
kernel-modules-extra-0:4.0.4-301.fc22.x86_64
kernel-modules-extra-0:4.0.4-303.fc22.x86_64

Actual results:
different output

Expected results:
similar output
Comment 1 Honza Silhan 2015-06-15 15:50:23 EDT
Thanks for the report. It shouldn't print installonly packages.
Comment 2 srakitnican 2015-07-31 11:32:39 EDT
Experiencing the same issue under F22.

$ rpm -q dnf
dnf-1.0.1-2.fc22.noarch

$ sudo dnf repoquery --duplicated
Last metadata expiration check performed 1:34:24 ago on Fri Jul 31 15:47:50 2015.
kernel-core-0:4.0.8-300.fc22.x86_64
kernel-core-0:4.1.2-200.fc22.x86_64
kernel-core-0:4.1.3-200.fc22.x86_64
kernel-debug-devel-0:4.0.8-300.fc22.x86_64
kernel-debug-devel-0:4.1.2-200.fc22.x86_64
kernel-debug-devel-0:4.1.3-200.fc22.x86_64
kernel-modules-0:4.0.8-300.fc22.x86_64
kernel-modules-0:4.1.2-200.fc22.x86_64
kernel-modules-0:4.1.3-200.fc22.x86_64
Comment 3 Fedora Update System 2015-11-16 14:07:03 EST
dnf-plugins-core-0.1.14-1.fc23 dnf-1.1.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe6e8b885b
Comment 4 Fedora Update System 2015-11-18 11:26:52 EST
dnf-1.1.4-1.fc22 dnf-plugins-core-0.1.14-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6137119aff
Comment 5 Fedora Update System 2015-11-18 11:52:06 EST
dnf-1.1.4-1.fc23, dnf-plugins-core-0.1.14-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-fe6e8b885b
Comment 6 Peter Bieringer 2015-11-19 01:39:58 EST
Looks like there is a conflict issue caused by additional dependencies:

# LC_ALL=C dnf --enablerepo=updates-testing update dnf dnf-plugins-core
Last metadata expiration check performed 0:00:56 ago on Thu Nov 19 06:57:53 2015.
Dependencies resolved.
======================================================================================================================================
 Package                                  Arch                   Version                        Repository                       Size
======================================================================================================================================
Upgrading:
 dnf                                      noarch                 1.1.4-1.fc23                   updates-testing                 265 k
 dnf-conf                                 noarch                 1.1.4-1.fc23                   updates-testing                  89 k
 dnf-plugins-core                         noarch                 0.1.14-1.fc23                  updates-testing                  36 k
 dnf-yum                                  noarch                 1.1.4-1.fc23                   updates-testing                  82 k
 python2-dnf                              noarch                 1.1.4-1.fc23                   updates-testing                 447 k
 python3-dnf                              noarch                 1.1.4-1.fc23                   updates-testing                 452 k
 python3-dnf-plugins-core                 noarch                 0.1.14-1.fc23                  updates-testing                  64 k

Transaction Summary
======================================================================================================================================
Upgrade  7 Packages

Total size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] dnf-1.1.4-1.fc23.noarch.rpm: Already downloaded                                                                                   
[SKIPPED] python3-dnf-1.1.4-1.fc23.noarch.rpm: Already downloaded                                                                           
[SKIPPED] dnf-conf-1.1.4-1.fc23.noarch.rpm: Already downloaded                                                                              
[SKIPPED] dnf-yum-1.1.4-1.fc23.noarch.rpm: Already downloaded                                                                               
[SKIPPED] python2-dnf-1.1.4-1.fc23.noarch.rpm: Already downloaded                                                                           
[SKIPPED] dnf-plugins-core-0.1.14-1.fc23.noarch.rpm: Already downloaded                                                                     
[SKIPPED] python3-dnf-plugins-core-0.1.14-1.fc23.noarch.rpm: Already downloaded                                                             
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/locale/ca/LC_MESSAGES/dnf-plugins-core.mo from install of python3-dnf-plugins-core-0.1.14-1.fc23.noarch conflicts with file from package python-dnf-plugins-core-0.1.13-1.fc23.noarch
  file /usr/share/locale/da/LC_MESSAGES/dnf-plugins-core.mo from install of python3-dnf-plugins-core-0.1.14-1.fc23.noarch conflicts with file from package python-dnf-plugins-core-0.1.13-1.fc23.noarch

Error Summary
-------------



Checks:

# rpm -ql python-dnf-plugins-core-0.1.13-1.fc23.noarch |grep locale
/usr/share/locale/ca/LC_MESSAGES/dnf-plugins-core.mo
/usr/share/locale/da/LC_MESSAGES/dnf-plugins-core.mo

# rpm -qlp python3-dnf-plugins-core-0.1.14-1.fc23.noarch.rpm | grep local
/usr/share/locale/ca/LC_MESSAGES/dnf-plugins-core.mo
/usr/share/locale/da/LC_MESSAGES/dnf-plugins-core.mo

Is there an "obsoletes" missing?

python3-dnf-plugins-core
 Obsoletes: python-dnf-plugins-core

Workaround:

# rpm -e python-dnf-plugins-core (able to do without dependencies...)


Then after update everything works fine:

# LC_ALL=C package-cleanup --dupes

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.


Loaded plugins: fastestmirror, langpacks
Comment 7 Fedora Update System 2015-11-19 04:52:08 EST
dnf-1.1.4-1.fc23, dnf-plugins-core-0.1.14-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-11-19 09:51:45 EST
dnf-1.1.4-1.fc22, dnf-plugins-core-0.1.14-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6137119aff
Comment 9 Fedora Update System 2015-11-30 18:23:49 EST
dnf-1.1.4-1.fc22, dnf-plugins-core-0.1.14-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.