Bug 1231619 - BitRot :- Handle brick re-connection sanely in bitd/scrub process
Summary: BitRot :- Handle brick re-connection sanely in bitd/scrub process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1226666
Blocks: 1226830 1231617 1232309
TreeView+ depends on / blocked
 
Reported: 2015-06-15 05:50 UTC by Venky Shankar
Modified: 2016-06-16 13:11 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1226666
: 1232309 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:11:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Venky Shankar 2015-06-15 05:50:57 UTC
+++ This bug was initially created as a clone of Bug #1226666 +++

Description: 
============
Upon brick disconnection (and reconnection), bitrot
daemons should able to recover sanely by handling the events as
cleaning up (or initing) as required.

--- Additional comment from Rachana Patel on 2015-05-31 11:57:29 EDT ---

shall update detail steps ASAP

--- Additional comment from Anand Avati on 2015-06-11 10:52:34 EDT ---

REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-11 10:52:36 EDT ---

REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-11 23:27:34 EDT ---

REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#4) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-15 00:20:04 EDT ---

REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#5) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 1 Anand Avati 2015-06-15 05:53:23 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#6) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 2 Anand Avati 2015-06-16 06:35:39 UTC
REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#7) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Anand Avati 2015-06-16 06:35:41 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#8) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 4 Anand Avati 2015-06-16 09:42:30 UTC
REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#8) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 5 Anand Avati 2015-06-16 09:42:32 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#9) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 6 Anand Avati 2015-06-17 04:11:47 UTC
REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#9) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 7 Anand Avati 2015-06-17 04:11:49 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#10) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 8 Anand Avati 2015-06-17 09:05:50 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#11) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 9 Anand Avati 2015-06-17 13:58:21 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#12) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 10 Anand Avati 2015-06-17 17:30:30 UTC
REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#12) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 11 Anand Avati 2015-06-17 17:30:38 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#13) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 12 Anand Avati 2015-06-17 17:31:12 UTC
REVIEW: http://review.gluster.org/11290 (tests/bitrot: Scrub state test(s)) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 13 Anand Avati 2015-06-18 00:36:29 UTC
REVIEW: http://review.gluster.org/11148 (features/bitrot: cleanup, v2) posted (#14) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 14 Anand Avati 2015-06-25 06:53:12 UTC
REVIEW: http://review.gluster.org/11149 (features/bitrot: handle scrub states via state machine) posted (#14) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 15 Anand Avati 2015-06-25 11:45:25 UTC
COMMIT: http://review.gluster.org/11148 committed in master by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 6ab37f0cb4fd8313dab93360a41acbaf422f39b5
Author: Venky Shankar <vshankar@redhat.com>
Date:   Thu Jun 4 08:50:48 2015 +0530

    features/bitrot: cleanup, v2
    
    This patch uses "cleanup, v1" infrastrcuture to cleanup scrubber
    (data structures, threads, timers, etc..) on brick disconnection.
    Signer is not cleaned up yet: probably would be done as part of
    another patch.
    
    Change-Id: I78a92b8a7f02b2f39078aa9a5a6b101fc499fd70
    BUG: 1231619
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11148
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 16 Anand Avati 2015-06-25 12:57:25 UTC
COMMIT: http://review.gluster.org/11149 committed in master by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 913631a0edffaefc0fae73df46f80e19422ebed9
Author: Venky Shankar <vshankar@redhat.com>
Date:   Tue Jun 9 10:02:11 2015 +0530

    features/bitrot: handle scrub states via state machine
    
    A bunch of command line options for scrubber tempted the use of
    state machine to track current state of scrubber under various
    circumstances where the options could be in effect.
    
    Change-Id: Id614bb2e6af30a90d2391ea31ae0a3edeb4e0d69
    BUG: 1231619
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11149
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 17 Niels de Vos 2016-06-16 13:11:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.