Bug 1231620 - scrub frequecny and throttle change information need to be present in Scrubber log
Summary: scrub frequecny and throttle change information need to be present in Scrubbe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1225747 1231024
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-15 05:51 UTC by Venky Shankar
Modified: 2016-06-16 13:12 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1231024
Environment:
Last Closed: 2016-06-16 13:12:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Venky Shankar 2015-06-15 05:51:30 UTC
+++ This bug was initially created as a clone of Bug #1231024 +++

+++ This bug was initially created as a clone of Bug #1225747 +++

Description of problem:
==========================
scrub frequecny and throttle change information need to be present in Scrubber log



Version-Release number of selected component (if applicable):
====================
scrub frequecny and throttle change information need to be present in Scrubber log


How reproducible:


Steps to Reproduce:
=====================
1.Create a volume and enable bitrot
2.Change the Scrubber frequency and throttle values but we are not logging this information in the log 
3.

Actual results:


Expected results:
====================
It would be good to log this information in the log for tracking and troubleshooting purpose

Comment 1 Anand Avati 2015-06-15 05:53:33 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#3) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 2 Anand Avati 2015-06-16 03:54:00 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#4) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 3 Anand Avati 2015-06-16 06:35:51 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#5) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 4 Anand Avati 2015-06-16 09:42:48 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#6) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 5 Anand Avati 2015-06-17 08:45:24 UTC
REVIEW: http://review.gluster.org/11263 (Revert "tests/bitrot: Induce delay before invoking bitrot subcommands") posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 6 Anand Avati 2015-06-17 09:06:25 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#8) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 7 Anand Avati 2015-06-17 13:59:26 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#9) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 8 Anand Avati 2015-06-17 17:30:49 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#10) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 9 Anand Avati 2015-06-18 00:36:45 UTC
REVIEW: http://review.gluster.org/11190 (features/bitrot: log scrub frequency & throttle values) posted (#11) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 10 Niels de Vos 2016-06-16 13:12:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.