Bug 123164 - illegal roff syntax in dmsetup manpage
illegal roff syntax in dmsetup manpage
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-13 09:52 EDT by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 03:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-05-13 09:52:08 EDT
Description of problem:
Reading the manpage of dmsetup gives an error message because of some 
syntax in the roff source.

Version-Release number of selected component (if applicable):
device-mapper-1.00.14-3

How reproducible:
always

Steps to Reproduce:
1. zcat /usr/share/man/man8/dmsetup.8.gz | nroff -man 1>/dev/null
2. or: man dmsetup
3.
  
Actual results:
<standard input>:74: warning: numeric expression expected (got `[')

Expected results:
no warning

Additional info:
Annoying, nothing more. ;-)
Comment 1 Peter van Egdom 2004-06-26 05:57:02 EDT
I can't reproduce this on Fedora Core release 2 (Tettnang) with the
following packages :

- device-mapper-1.00.14-3
- groff-1.18.1-34
- man-1.5m2-6

Are you using FC2 test3? If so, try upgrading to FC2 final or above
packages.
Comment 2 Moritz Barsnick 2004-06-28 03:10:07 EDT
Okay, you got me on this one. Since my update to FC2, I cannot 
reproduce this either. I cannot - at this moment - figure out which 
groff package I actually had when I filed the bug. I might check.

For the time being, I'll just close this little tidbit as "works for 
me".

Thanks, Peter!

Note You need to log in before you can comment on or make changes to this bug.