Bug 1231812 - git-cola-2.3 is available
git-cola-2.3 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: git-cola (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-15 08:43 EDT by Upstream Release Monitoring
Modified: 2015-08-22 20:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.3-1.fc21
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-22 18:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for spec file (982 bytes, patch)
2015-07-16 03:22 EDT, Kai Morwinski
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-06-15 08:43:55 EDT
Latest upstream release: v2.2
Current version/release in rawhide: 2.1.2-1.fc23
URL: https://github.com/git-cola/git-cola

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-06-15 08:44:12 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-6wUVXu/git-cola.spec
return code:  22
stdout:
Getting https://github.com/git-cola/git-cola/archive/vv2.2/git-cola-v2.2.tar.gz to ./git-cola-v2.2.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   138    0   138    0     0    254      0 --:--:-- --:--:-- --:--:--   253

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 2 Upstream Release Monitoring 2015-06-15 20:42:51 EDT
Latest upstream release: v2.2.1
Current version/release in rawhide: 2.1.2-1.fc23
URL: https://github.com/git-cola/git-cola

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2015-06-15 20:43:07 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-tvC9yN/git-cola.spec
return code:  22
stdout:
Getting https://github.com/git-cola/git-cola/archive/vv2.2.1/git-cola-v2.2.1.tar.gz to ./git-cola-v2.2.1.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   142    0   142    0     0    272      0 --:--:-- --:--:-- --:--:--   272

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 4 Kai Morwinski 2015-07-16 03:22:31 EDT
Created attachment 1052580 [details]
patch for spec file

Tested on FC21, builds and runs fine.
Comment 5 Upstream Release Monitoring 2015-08-10 08:14:40 EDT
Latest upstream release: v2.3
Current version/release in rawhide: 2.1.2-2.fc23
URL: https://github.com/git-cola/git-cola

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 6 Upstream Release Monitoring 2015-08-10 08:14:54 EDT
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-xFermX/git-cola.spec
return code:  22
stdout:
Getting https://github.com/git-cola/git-cola/archive/vv2.3/git-cola-v2.3.tar.gz to ./git-cola-v2.3.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   138    0   138    0     0    271      0 --:--:-- --:--:-- --:--:--   271

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
Comment 7 David Aguilar 2015-08-10 16:33:35 EDT
Unlike earlier releases, this one has a two-part (not three-part) version number.  v2.3 instead of v2.1.2 like the previous one.

Is that tripping up the downloader?  It seems to be trying to grab ".../archive/vv2.3/..." -- it has two v's in the URL for some reason.

Maybe the watch URL regex needs to be adjusted?
Comment 8 Kevin Kofler 2015-08-10 19:45:48 EDT
The vv thing has been there all the time, see the previous bug comments. So it's not the version number that's causing the problem.
Comment 9 Upstream Release Monitoring 2015-08-10 19:52:47 EDT
Latest upstream release: 2.3
Current version/release in rawhide: 2.1.2-2.fc23
URL: https://github.com/git-cola/git-cola

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 10 Upstream Release Monitoring 2015-08-10 19:53:06 EDT
Failed to kick off scratch build.

cmd:  sha256sum /var/tmp/thn-Sx_6Sf/100.0%
return code:  1
stdout:

stderr:
sha256sum: /var/tmp/thn-Sx_6Sf/100.0%: No such file or directory
Comment 11 Kevin Kofler 2015-08-10 19:56:24 EDT
The problem is that the default regex on Anitya (the upstream release monitoring system) assumes tags that are ONLY the version number, whereas you use v + version number. I fixed the regex on Anitya (I manually entered one that works) and flagged the package for an admin to delete the bogus version numbers with the "v".
Comment 12 Upstream Release Monitoring 2015-08-10 20:20:55 EDT
kkofler's git-cola-2.3-1.fc24 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=676607
Comment 13 Kevin Kofler 2015-08-10 20:27:15 EDT
Hi davvid,

the build.log shows these warnings during documentation generation:
> loading intersphinx inventory from http://docs.python.org/objects.inv...
> WARNING: intersphinx inventory 'http://docs.python.org/objects.inv' not fetchable due to <class 'urllib.error.URLError'>: <urlopen error [Errno -5] No address associated with hostname>

This is because Koji does not allow the builds to connect to the Internet. (It is also generally a bad idea to depend on online resources during the build.)
Comment 14 Fedora Update System 2015-08-11 20:26:39 EDT
git-cola-2.3-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/git-cola-2.3-1.fc23
Comment 15 Fedora Update System 2015-08-11 20:28:29 EDT
git-cola-2.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/git-cola-2.3-1.fc22
Comment 16 Fedora Update System 2015-08-11 20:29:08 EDT
git-cola-2.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/git-cola-2.3-1.fc21
Comment 17 Fedora Update System 2015-08-13 12:56:42 EDT
Package git-cola-2.3-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-cola-2.3-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13400/git-cola-2.3-1.fc22
then log in and leave karma (feedback).
Comment 18 David Aguilar 2015-08-14 04:28:29 EDT
Thanks for the heads up, Kevin. I'll remove the intersphinx directives in the next release.  It should be okay to ignore them for now, if possible.  Does that fail the koji build, or just warn?  In any case, it'll be fixed upstream shortly.
Comment 19 Kevin Kofler 2015-08-14 05:48:25 EDT
It's just a warning. I did the builds and submitted the updates anyway.
Comment 20 Fedora Update System 2015-08-18 01:25:44 EDT
git-cola-2.3-1.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2015-08-22 18:50:07 EDT
git-cola-2.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2015-08-22 20:48:17 EDT
git-cola-2.3-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.