Bug 1231832 - bitrot: (rfe) object signing wait time value should be tunable.
Summary: bitrot: (rfe) object signing wait time value should be tunable.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact: RajeshReddy
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1228680
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-15 13:03 UTC by Gaurav Kumar Garg
Modified: 2016-07-13 22:34 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1228680
Environment:
Last Closed: 2015-06-20 09:51:16 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Gaurav Kumar Garg 2015-06-15 13:03:42 UTC
+++ This bug was initially created as a clone of Bug #1228680 +++

Description of problem:

Currently bitrot using 120 sec wait time for object to signing after releasing all the fops. This waiting time value should be tunable for QA testing.

Version-Release number of selected component (if applicable):
Mainline.

--- Additional comment from Anand Avati on 2015-06-05 08:49:41 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-06-11 09:39:59 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-06-11 10:07:58 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#5) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-06-12 06:29:50 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#7) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-12 06:51:17 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#8) for review on master by Venky Shankar (vshankar@redhat.com)

--- Additional comment from Anand Avati on 2015-06-15 02:30:01 EDT ---

REVIEW: http://review.gluster.org/11105 (features/bitrot: tuanble object signing waiting time value for bitrot) posted (#9) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-06-15 08:23:52 EDT ---

COMMIT: http://review.gluster.org/11105 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 554fa0c1315d0b4b78ba35a2d332d7ac0fd07d48
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Fri Jun 5 13:58:28 2015 +0530

    features/bitrot: tuanble object signing waiting time value for bitrot
    
     Currently bitrot using 120 second waiting time for object to be signed
     after all fop's released. This signing waiting time value should be tunable.
    
     Command for changing the signing waiting time will be
     #gluster volume bitrot <VOLNAME> signing-time <waiting time value in second>
    
    Change-Id: I89f3121564c1bbd0825f60aae6147413a2fbd798
    BUG: 1228680
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11105

Comment 1 Anand Avati 2015-06-17 16:39:05 UTC
COMMIT: http://review.gluster.org/11235 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 8a7dfb0d4b856578e89898c2bb84a0a675ade50b
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Fri Jun 5 13:58:28 2015 +0530

    features/bitrot: tuanble object signing waiting time value for bitrot
    
     Currently bitrot using 120 second waiting time for object to be signed
     after all fop's released. This signing waiting time value should be tunable.
    
     Command for changing the signing waiting time will be
     #gluster volume bitrot <VOLNAME> signing-time <waiting time value in second>
    
    Change-Id: I89f3121564c1bbd0825f60aae6147413a2fbd798
    BUG: 1231832
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/11105
    (cherry picked from commit 554fa0c1315d0b4b78ba35a2d332d7ac0fd07d48)
    Reviewed-on: http://review.gluster.org/11235
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 2 Niels de Vos 2015-06-20 09:51:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.