Bug 1231834 - kadmind cannot start with service / systemctl due to incorrect /usr/sbin/_kadmind
Summary: kadmind cannot start with service / systemctl due to incorrect /usr/sbin/_kad...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: 22
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Roland Mainz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-15 13:06 UTC by Patrik Kis
Modified: 2015-09-08 17:27 UTC (History)
6 users (show)

Fixed In Version: krb5-1.13.2-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-21 00:18:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Patrik Kis 2015-06-15 13:06:33 UTC
Description of problem:
kadmid can not be started because /usr/sbin/_kadmind can not be executed
Looks like a file encoding issue.

Version-Release number of selected component (if applicable):
krb5-server-1.13.2-2.fc22

How reproducible:
always

Steps to Reproduce:

[root@fed22 ~]$ service kadmin start 
Redirecting to /bin/systemctl start  kadmin.service
Job for kadmin.service failed. See "systemctl status kadmin.service" and "journalctl -xe" for details.
[root@fed22 ~]$ service kadmin status
Redirecting to /bin/systemctl status  kadmin.service
● kadmin.service - Kerberos 5 Password-changing and Administration
   Loaded: loaded (/usr/lib/systemd/system/kadmin.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2015-06-15 08:58:03 EDT; 7s ago
  Process: 2678 ExecStart=/usr/sbin/_kadmind -P /var/run/kadmind.pid $KADMIND_ARGS (code=exited, status=203/EXEC)
 Main PID: 1964 (code=exited, status=2)

Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[1]: Starting Kerberos 5 Password-changing and Administration...
Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[2678]: Failed at step EXEC spawning /usr/sbin/_kadmind: Exec format error
Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[1]: kadmin.service: control process exited, code=exited status=203
Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[1]: Failed to start Kerberos 5 Password-changing and Administration.
Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[1]: Unit kadmin.service entered failed state.
Jun 15 08:58:03 hp-dl80gen9-01.khw.lab.eng.bos.redhat.com systemd[1]: kadmin.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
[root@fed22 ~]$ cat /usr/sbin/_kadmind

@kadmind=/usr/sbin/kadmind@@test-f!/var/kerberos/krb5kdc/kpropd.acl@echo>$"Error. This appears to be a slave server, found kpropd.acl"@exit	@@test-x
                              "$kadmind"$
                                         @exit
                                                 @@exec
                                                         "$kadmind"$"$@"$[root@fed22 ~]$ 
[root@fed22 ~]$ file /usr/sbin/_kadmind:
/usr/sbin/_kadmind:: cannot open `/usr/sbin/_kadmind:' (No such file or directory)
[root@fed22 ~]$ file /usr/sbin/_kadmind
/usr/sbin/_kadmind: data
[root@fed22 ~]$ ls -l /usr/sbin/_kadmind
-rwxr-xr-x. 1 root root 247 Jun  2 21:29 /usr/sbin/_kadmind
[root@fed22 ~]$ 
[root@fed22 ~]$ rm -rf /usr/sbin/_kadmind && yum -y reinstall krb5-server-1.13.2-2.fc22.x86_64.rpm
Yum command has been deprecated, redirecting to '/usr/bin/dnf -y reinstall krb5-server-1.13.2-2.fc22.x86_64.rpm'.
See 'man dnf' and 'man yum2dnf' for more information.
To transfer transaction metadata from yum to DNF, run:
'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Last metadata expiration check performed 0:20:20 ago on Mon Jun 15 08:38:15 2015.
Dependencies resolved.
============================================================================================================================================
 Package                          Arch                        Version                               Repository                         Size
============================================================================================================================================
Reinstalling:
 krb5-server                      x86_64                      1.13.2-2.fc22                         @commandline                      918 k

Transaction Summary
============================================================================================================================================

Total size: 918 k
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Reinstalling: krb5-server-1.13.2-2.fc22.x86_64                                                                                        1/2 
  Erasing     : krb5-server-1.13.2-2.fc22.x86_64                                                                                        2/2 
  Verifying   : krb5-server-1.13.2-2.fc22.x86_64                                                                                        1/2 
  Verifying   : krb5-server-1.13.2-2.fc22.x86_64                                                                                        2/2 

Reinstalled:
  krb5-server.x86_64 1.13.2-2.fc22                                                                                                          

Complete!
[root@fed22 ~]$ cat /usr/sbin/_kadmind

@kadmind=/usr/sbin/kadmind@@test-f!/var/kerberos/krb5kdc/kpropd.acl@echo>$"Error. This appears to be a slave server, found kpropd.acl"@exit	@@test-x
                              "$kadmind"$
                                         @exit
                                                 @@exec
                                                         "$kadmind"$"$@"$[root@fed22 ~]$ 
[root@fed22 ~]$ 
[root@fed22 ~]$ od -a /usr/sbin/_kadmind
0000000  vt dc3  bs nul etx nul nul   @ sub   k   a   d   m   i   n   d
0000020   =   /   u   s   r   /   s   b   i   n   /   k   a   d   m   i
0000040   n   d dc1 nul   @ ack eot nul   @ nul etx enq   t   e   s   t
0000060 etx   -   f   !   /   v   a   r   /   k   e   r   b   e   r   o
0000100   s   /   k   r   b   5   k   d   c   /   k   p   r   o   p   d
0000120   .   a   c   l nul bel etx dle   @ nul enq   e   c   h   o soh
0000140   >   $   "   E   r   r   o   r   .  sp   T   h   i   s  sp   a
0000160   p   p   e   a   r   s  sp   t   o  sp   b   e  sp   a  sp   s
0000200   l   a   v   e  sp   s   e   r   v   e   r   ,  sp   f   o   u
0000220   n   d  sp   k   p   r   o   p   d   .   a   c   l   "   d nul
0000240  bs nul   @ nul stx enq   e   x   i   t stx   6 nul  ht   @ eot
0000260  gs dle   @ nul enq   t   e   s   t soh etx   -   x soh  vt   "
0000300   $   k   a   d   m   i   n   d   "   $ nul  vt nul   @ nul stx
0000320 enq   e   x   i   t stx   5 nul  ff   @ dle   @ nul enq   e   x
0000340   e   c soh  vt   "   $   k   a   d   m   i   n   d   "   $ enq
0000360   "   $   @   "   $ nul  so
0000367
[root@fed22 ~]$

Comment 1 Roland Mainz 2015-06-15 13:11:10 UTC
Taking bug... it's an (unintended) side-effect of the Zanata (l10n) changes for localisation... ;-/

Comment 2 Roland Mainz 2015-06-15 22:09:36 UTC
Workaround: After package update execute a:
$ systemctl restart systemd-binfmt.service # ... but I have no idea (yet...) how to do that as part of the rpm update ... ;-(

Comment 3 Jan Pazdziora 2015-06-18 13:07:27 UTC
Please stop https://admin.fedoraproject.org/updates/FEDORA-2015-10087/krb5-1.13.2-2.fc22 from going out -- people are eager to give it +1'es without testing kadmind service.

Comment 4 Roland Mainz 2015-06-18 21:02:37 UTC
Test builds are available as  http://koji.fedoraproject.org/koji/taskinfo?taskID=10145036 ... I'll push that fix to F23/F22 as soon as someone can confirm that this fixes the rpm update issue we see here...

Comment 5 Jan Pazdziora 2015-06-19 08:24:27 UTC
(In reply to Roland Mainz from comment #4)
> Test builds are available as 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=10145036 ... I'll push
> that fix to F23/F22 as soon as someone can confirm that this fixes the rpm
> update issue we see here...

Please make a Fedora 22 build.

Also, not sure what rpm update issue you have in mind -- my understanding of this issue is that /usr/sbin/_kadmind is broken. I can see the issue on fresh installation.

Comment 6 Roland Mainz 2015-06-19 15:50:49 UTC
(In reply to Roland Mainz from comment #4)
> Test builds are available as 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=10145036 ... I'll push
> that fix to F23/F22 as soon as someone can confirm that this fixes the rpm
> update issue we see here...

See http://koji.fedoraproject.org/koji/taskinfo?taskID=10166169 for the F22 build. I can push the fix as soon as I have a confirmation that this works.

Comment 7 Patrik Kis 2015-06-19 16:35:53 UTC
I tried krb5-1.13.2-3.fc22 and kadmind stated, but now I can not reproduce the issue when downgrading to the reported version. I need to check it once more.

Comment 8 Fedora Update System 2015-06-19 17:17:00 UTC
krb5-1.13.2-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/krb5-1.13.2-3.fc22

Comment 9 Roland Mainz 2015-06-19 17:17:36 UTC
Issue should be fixed in krb5-1.13.2-3.fc22 and krb5-1.13.2-4.fc23 ...

Comment 10 Fedora Update System 2015-06-21 00:18:40 UTC
krb5-1.13.2-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.