Bug 1231844 - [abrt] gnome-abrt: PyBytes_AsString(): python3.4 killed by SIGSEGV
Summary: [abrt] gnome-abrt: PyBytes_AsString(): python3.4 killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-abrt
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b39e40f06d4daee2be6ac35944e...
: 1222243 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-15 13:25 UTC by Kamil Páral
Modified: 2016-12-01 00:48 UTC (History)
4 users (show)

Fixed In Version: gnome-abrt-1.2.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-25 08:24:47 UTC


Attachments (Terms of Use)
File: backtrace (160.51 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: cgroup (190 bytes, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: core_backtrace (24.74 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: dso_list (17.27 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: environ (1.86 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: limits (1.29 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: maps (79.75 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: mountinfo (3.64 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: namespaces (85 bytes, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: open_fds (1.74 KB, text/plain)
2015-06-15 13:25 UTC, Kamil Páral
no flags Details
File: proc_pid_status (960 bytes, text/plain)
2015-06-15 13:26 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2015-06-15 13:25:42 UTC
Description of problem:
This happens every time I try to start ABRT from GNOME.

Version-Release number of selected component:
gnome-abrt-1.1.2-2.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/gnome-abrt
crash_function: PyBytes_AsString
executable:     /usr/bin/python3.4
global_pid:     4340
kernel:         4.0.4-303.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: [System Logs]:\n-- Logs begin at Fri 2015-03-13 16:55:58 CET, end at Fri 2015-06-12 18:01:40 CEST. --

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 PyBytes_AsString at /usr/src/debug/Python-3.4.2/Objects/bytesobject.c:542
 #1 p_get_app_for_env at problem_app.c:57
 #2 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4263
 #3 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #4 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #5 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288
 #6 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #7 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #8 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288
 #9 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860

Comment 1 Kamil Páral 2015-06-15 13:25:46 UTC
Created attachment 1039041 [details]
File: backtrace

Comment 2 Kamil Páral 2015-06-15 13:25:47 UTC
Created attachment 1039042 [details]
File: cgroup

Comment 3 Kamil Páral 2015-06-15 13:25:49 UTC
Created attachment 1039043 [details]
File: core_backtrace

Comment 4 Kamil Páral 2015-06-15 13:25:50 UTC
Created attachment 1039044 [details]
File: dso_list

Comment 5 Kamil Páral 2015-06-15 13:25:51 UTC
Created attachment 1039045 [details]
File: environ

Comment 6 Kamil Páral 2015-06-15 13:25:53 UTC
Created attachment 1039046 [details]
File: limits

Comment 7 Kamil Páral 2015-06-15 13:25:55 UTC
Created attachment 1039047 [details]
File: maps

Comment 8 Kamil Páral 2015-06-15 13:25:57 UTC
Created attachment 1039048 [details]
File: mountinfo

Comment 9 Kamil Páral 2015-06-15 13:25:58 UTC
Created attachment 1039049 [details]
File: namespaces

Comment 10 Kamil Páral 2015-06-15 13:25:59 UTC
Created attachment 1039050 [details]
File: open_fds

Comment 11 Kamil Páral 2015-06-15 13:26:00 UTC
Created attachment 1039051 [details]
File: proc_pid_status

Comment 12 Jakub Filak 2015-06-16 13:22:35 UTC
Thank you for the report! gnome-abrt crashes because your environment variables contain non-ASCII data and gnome-abrt tries to read them as ASCII.

Comment 13 Jakub Filak 2015-06-16 15:00:06 UTC
Upstream commit https://github.com/abrt/gnome-abrt/commit/b95e9b2eff6541d03a4c490d46bce068b2c98499 fixes this bug.

Comment 14 Fedora Update System 2015-06-22 08:45:41 UTC
gnome-abrt-1.2.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-abrt-1.2.0-2.fc22

Comment 15 Fedora Update System 2015-06-23 09:07:27 UTC
Package gnome-abrt-1.2.0-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-1.2.0-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10521/gnome-abrt-1.2.0-2.fc22
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2015-06-25 08:24:47 UTC
gnome-abrt-1.2.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Jakub Filak 2016-08-02 09:20:16 UTC
*** Bug 1222243 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.