Bug 123198 - /etc/pam.d/smtp deleted on postfix upgrade when sendmail installed
/etc/pam.d/smtp deleted on postfix upgrade when sendmail installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: postfix (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-05-13 15:22 EDT by kop
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kop 2004-05-13 15:22:44 EDT
Description of problem:
Both sendmail and postfix are installed.  I've a nightly
cron job running up2date.  Last night it installed
postfix-2.0.16-13.RHEL3 and now /etc/pam.d/smtp is
missing.

Version-Release number of selected component (if applicable):
postfix-2.0.16-13.RHEL3 

How reproducible:
Don't know.

Steps to Reproduce:
1.  Install postfix
2.  Leave sendmail installed
3.  Use "alternatives --config mta" and choose postfix
4.  Update postfix with 
  
Actual results:


Expected results:


Additional info:
Prevents users from authenticating before sending mail.
(When /usr/lib/sasl/smtpd.auth says pam, which mine does
not yet.)
Comment 1 Thomas Woerner 2004-05-21 05:33:43 EDT
What happens, if you call

/usr/sbin/alternatives --set mta /usr/sbin/sendmail.postfix

by hand?
Comment 2 Johnny Hughes 2004-05-21 21:03:25 EDT
also missing is /etc/sysconfig/saslauthd after upgrading postfix.

Manually creating the file /etc/sysconfig/saslauthd and placing
"mech=pam" in it made everything work again....
Comment 3 kop 2004-05-22 13:41:48 EDT
I ran an alternatives command, perhaps
"alternatives --config mta postfix" (??) when I
first installed the system to make postfix
the default mailer. (Step 3 above.)

It was up2date, the batch of updates, which came out
on 2004-05-12 the day before I created this bug, that broke things.
This included a postfix update.

(I don't know how 'step 4' above got truncated.  Sorry.)

In any case, I've since removed sendmail from my system
so it's no longer a good platform for testing this problem.
At least not if it's sendmail related.

I'm reluctant to try your suggestion at the moment as
I don't want to interfere with regular system operation.
I will be able to get around to it if you're willing to
wait.
Comment 4 Jay Turner 2004-09-02 01:13:51 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-362.html

Note You need to log in before you can comment on or make changes to this bug.