Bug 123204 - pkgorder requires additional files
Summary: pkgorder requires additional files
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-13 19:36 UTC by Hrunting Johnson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 19:40:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hrunting Johnson 2004-05-13 19:36:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
anaconda-runtime is great, because you install the files necessary to
rebuild distributions without installing the entire anaconda package
which has some many dependencies it's sick.  However, an important
part of the anaconda-runtime package is pkgorder, which requires
several python libraries not distributed with anaconda-runtime
(whiteout, anaconda_log, flags, etc.).  Some are found in rpm-python,
the others in anaconda.

Is there any chance that an anaconda-runtime can be built that has
these files without requiring every other single library installed
with Fedora?

Version-Release number of selected component (if applicable):
anaconda-runtime-9.92-8

How reproducible:
Always

Steps to Reproduce:
1. install anaconda-runtime rpm
2. run pkgorder
3.
    

Actual Results:  pkgorder craps out because it can't find rpm (or
whiteout, or anaconda_log, etc. etc.)

Expected Results:  pkgorder works fine, without the necessary bloat of
the entire anaconda package being installed

Additional info:

This looks to be a problem at least as far back as Redhat 9.

Comment 1 Jeremy Katz 2004-05-13 19:40:27 UTC
Unfortunately, pkgorder requires these things to function. 
anaconda-runtime doesn't have the deps on the specific packages like
anaconda to allow running things like genhdlist without a full system.


Note You need to log in before you can comment on or make changes to this bug.