Bug 1232135 - Quota: " E [quota.c:1197:quota_check_limit] 0-ecvol-quota: Failed to check quota size limit" in brick logs
Summary: Quota: " E [quota.c:1197:quota_check_limit] 0-ecvol-quota: Failed to check q...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Vijaikumar Mallikarjuna
QA Contact:
URL:
Whiteboard:
Depends On: 1229606 1229609
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-16 06:36 UTC by Vijaikumar Mallikarjuna
Modified: 2016-05-11 22:48 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1229609
Environment:
Last Closed: 2015-06-20 09:51:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-16 06:37:31 UTC
REVIEW: http://review.gluster.org/11242 (quota: don't log error when disk quota exceeded) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2015-06-17 12:16:25 UTC
COMMIT: http://review.gluster.org/11242 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 08e404e9d397004ad24f3734862632fbeb66f2b0
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jun 9 12:57:29 2015 +0530

    quota: don't log error when disk quota exceeded
    
    This is a backport of http://review.gluster.org/#/c/11135
    
    > When disk quota exceeded, quota enforcer logs
    > alert message, so no need to log error message
    > as this can fill up the log file
    >
    > Change-Id: Ia913f47bc0cedb7c0a9c611330ee5124d3bb6c9d
    > BUG: 1229609
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I7b0b91965d8eb1b38ef6fa5ce0276a6b6da3372d
    BUG: 1232135
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11242
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Niels de Vos 2015-06-20 09:51:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.