Bug 123217 - dhcp 3.0.1 rc13 is available
Summary: dhcp 3.0.1 rc13 is available
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-13 21:20 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 3.0.1rc13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-12 11:18:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcp-3.0.1rc13-dhcpctlman.patch (946 bytes, patch)
2004-05-13 21:21 UTC, Robert Scheck
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Robert Scheck 2004-05-13 21:20:20 UTC
Description of problem:
dhcp 3.0.1 rc13 is available since February 6th, 2004 and Fedora 
Development is hanging around the older 3.0.1rc12.

Version-Release number of selected component (if applicable):
dhcp-3.0.1rc12-4
  
Actual results:
The following upgrade works for me, that's what I did:

--- snipp ---
--- dhcp.spec       2004-05-13 22:56:37.000000000 +0200
+++ dhcp.spec.rsc   2004-05-13 23:15:05.000000000 +0200
@@ -1,8 +1,8 @@
 Summary: A DHCP (Dynamic Host Configuration Protocol) server and relay agent.
 Name: dhcp
 Epoch: 1
-Version: 3.0.1rc12
-Release: 4
+Version: 3.0.1rc13
+Release: 1
 Copyright: distributable
 Group: System Environment/Daemons
 Source0: ftp://ftp.isc.org/isc/dhcp/dhcp-%{version}.tar.gz
@@ -11,11 +11,10 @@
 Source3: dhcrelay.init
 Patch: dhcp-3.0-alignment.patch
 Patch100: dhcp-3.0-jbuild.patch
-Patch102: dhcp-3.0pl1-dhcpctlman-69731.patch
+Patch102: dhcp-3.0.1rc13-dhcpctlman.patch
 Patch103: dhcp-3.0pl1-miscfixes.patch
 Patch106: dhcp-3.0pl1-minires.patch
 Patch109: dhcpd-manpage.patch
-Patch112: dhcp-3.0pl2-div0.patch
 Patch113: dhcp-3.0pl2-selinux.patch
 Patch114: dhcp-3.0pl2-initialize.patch
 Patch115: dhcp-3.0.1rc12-RHscript.patch
@@ -68,11 +67,10 @@

 %patch -p1 -b .alignment
 %patch100 -p1 -b .jbuild
-%patch102 -p1
+%patch102 -p1 -b .dhcpctlman
 %patch103 -p1 -b .miscfixes
 %patch106 -p1 -b .minires
 %patch109 -p1 -b .dhcpdman
-%patch112 -p1 -b .div0
 %patch113 -p1 -b .selinux
 %patch114 -p1 -b .initialize
 %patch115 -p1 -b .RHscript
@@ -154,7 +152,7 @@

 %files
 %defattr(-,root,root)
-%doc CHANGES README RELNOTES dhcpd.conf.sample
+%doc README RELNOTES dhcpd.conf.sample
 %dir %{_localstatedir}/lib/dhcp
 %verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/dhcp/dhcpd.leases
 %config(noreplace) /etc/sysconfig/dhcpd
--- snapp ---

Expected results:
Upgrade to 3.0.1 rc13

Additional info:
I removed Patch112 (dhcp-3.0pl2-div0.patch) for my use, because I
think, it's enough randomness there after the code rewrite - maybe
you write a new patch if you don't think so, because the old patch
doesn't apply any longer.

Comment 1 Robert Scheck 2004-05-13 21:21:21 UTC
Created attachment 100223 [details]
dhcp-3.0.1rc13-dhcpctlman.patch

Comment 2 Robert Scheck 2004-06-12 11:18:22 UTC
Thank you for doing the update :)

Comment 3 John Flanagan 2004-12-21 19:42:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.