Bug 1232267 - Some applications are hidden in the Applications list
Summary: Some applications are hidden in the Applications list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1232249
Blocks: 1196951
TreeView+ depends on / blocked
 
Reported: 2015-06-16 11:48 UTC by Vadim Rutkovsky
Modified: 2015-07-30 01:09 UTC (History)
5 users (show)

Fixed In Version: gnome-menus-3.13.3-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of: 1232249
Environment:
Last Closed: 2015-06-25 08:22:51 UTC


Attachments (Terms of Use)

Description Vadim Rutkovsky 2015-06-16 11:48:29 UTC
Happens in F22 too:
gnome-session-3.16.0-1.fc22.x86_64
gnome-shell-extension-apps-menu-3.16.1-2.fc22.noarch

+++ This bug was initially created as a clone of Bug #1232249 +++

Description of problem:
Some apps with 'OnlyShowIn=GNOME' are not displayed in Applications menu

Version-Release number of selected component (if applicable):
gnome-session-3.14.0-3.el7.x86_64
gnome-shell-extension-apps-menu-3.14.4-4.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open 'Applications' menu in gnome-classic session
2. Check apps in 'Accessories' menu

Actual results:
'Contacts' is hidden

Expected results:
'Contacts' is displayed

Additional info:
After line 'OnlyShowIn=GNOME;Unity' was commented in /usr/share/applications/org.gnome.Contacts.desktop and 'sudo update-desktop-database' was run the app is displayed again. Apparently gnome-session handles session name incorrecly

--- Additional comment from Vadim Rutkovsky on 2015-06-16 07:35:42 EDT ---

Changing component since it appears in Overview properly

Comment 1 Fedora Update System 2015-06-18 11:04:34 UTC
gnome-menus-3.13.3-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-menus-3.13.3-3.fc22

Comment 2 Fedora Update System 2015-06-21 00:22:40 UTC
Package gnome-menus-3.13.3-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-menus-3.13.3-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10153/gnome-menus-3.13.3-3.fc22
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2015-06-25 08:22:51 UTC
gnome-menus-3.13.3-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2015-07-14 18:54:40 UTC
gnome-menus-3.13.3-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-menus-3.13.3-3.fc21

Comment 5 Fedora Update System 2015-07-30 01:09:01 UTC
gnome-menus-3.13.3-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.