Bug 1232304 - libglusterfs: delete duplicate code in libglusterfs/src/dict.c
Summary: libglusterfs: delete duplicate code in libglusterfs/src/dict.c
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-16 13:02 UTC by Prasanna Kumar Kalever
Modified: 2016-06-16 13:12 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 13:12:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2015-06-16 13:02:50 UTC
Description of problem:
duplicate code found in 'dict_set_static_bin' function

Version-Release number of selected component (if applicable):
mainline

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-23 06:08:51 UTC
REVIEW: http://review.gluster.org/11255 (libglusterfs: delete duplicate code) posted (#2) for review on master by Prasanna Kumar Kalever

Comment 2 Anand Avati 2015-06-28 20:45:57 UTC
REVIEW: http://review.gluster.org/11255 (libglusterfs: delete duplicate code) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Anand Avati 2015-07-12 21:28:57 UTC
COMMIT: http://review.gluster.org/11255 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit d5246b38e68e80136bfc2a1c570189537b9de1ce
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Tue Jun 16 18:16:18 2015 +0530

    libglusterfs: delete duplicate code
    
    This patch saves cpu cyles by deleting duplicated code in most frequently
    used functions 'dict_set_static_bin' & 'dict_set_bin'  which is already
    repeated/executed in function 'bin_to_data'
    
    Change-Id: I8e18b3f2b321e06bb6bd5a67e1782cb159182dd2
    BUG: 1232304
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/11255
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Anand Avati 2015-07-18 11:17:14 UTC
REVIEW: http://review.gluster.org/11716 (dict: merge static/non-static dict_set_* variations) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 5 Anand Avati 2015-07-20 09:23:21 UTC
REVIEW: http://review.gluster.org/11716 (dict: merge static/non-static dict_set_* variations) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 6 Anand Avati 2015-07-21 07:10:43 UTC
REVIEW: http://review.gluster.org/11716 (dict: merge static/non-static dict_set_* variations) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 7 Niels de Vos 2016-06-16 13:12:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.