Bug 1232313 - 'openstack baremetal list' doesn't show proper error message when stackrc credentials are not loaded
Summary: 'openstack baremetal list' doesn't show proper error message when stackrc cre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ironicclient
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ga
: Director
Assignee: Brad P. Crochet
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-16 13:14 UTC by Marius Cornea
Modified: 2015-08-05 13:53 UTC (History)
8 users (show)

Fixed In Version: python-ironicclient-0.5.1-7.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-06-16 13:14:41 UTC
Description of problem:
openstack baremetal list doesn't show proper error message when stackrc credentials are not loaded.

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.7-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run 'openstack baremetal list' without sourcing stackrc file
2.
3.

Actual results:
[stack@instack ~]$ openstack baremetal list
ERROR: openstack __init__() takes exactly 2 arguments (1 given)

Expected results:
I'd expect to see an authorization failed message.

Additional info:

Comment 4 Brad P. Crochet 2015-06-18 22:09:00 UTC
PR available: https://github.com/rdo-management/python-ironicclient/pull/2

Comment 7 errata-xmlrpc 2015-08-05 13:53:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.