Bug 123239 - oops on atmel_cs ifup
oops on atmel_cs ifup
Status: CLOSED DUPLICATE of bug 123918
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-14 14:14 EDT by Bastien Nocera
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-05-14 14:14:40 EDT
Nice oops on ifup

See http://www.uwsg.iu.edu/hypermail/linux/kernel/0404.2/1604.html

Happens with kernel-2.6.5-1.358, didn't happen with previous kernels.
Can you apply the crappy hack until it's fixed, pretty please? :)

May 14 08:39:39 wyatt cardmgr[2924]: watching 1 socket
May 14 08:39:39 wyatt kernel: cs: IO port probe 0x0c00-0x0cff: clean.
May 14 08:39:39 wyatt kernel: cs: IO port probe 0x0100-0x04ff:
excluding 0x290-0x297 0x480-0x48f 0x4d0-0x4d7
May 14 08:39:39 wyatt kernel: cs: IO port probe 0x0a00-0x0aff: clean.
May 14 08:39:39 wyatt kernel: cs: memory probe 0xa0000000-0xa0ffffff:
clean.
May 14 08:39:39 wyatt cardmgr[2925]: socket 0: Actiontec wireless
May 14 08:39:40 wyatt kernel: eth0: MAC address 00:20:e0:5e:27:df
May 14 08:39:40 wyatt kernel: eth0: Atmel at76c50x wireless. Version
0.96 simon@thekelleys.org.uk
May 14 08:39:40 wyatt kernel: eth0: Actiontec 802CAT1 index 0x01: Vcc
3.3, irq 11, io 0x0100-0x011f
May 14 08:39:40 wyatt kernel: ip_tables: (C) 2000-2002 Netfilter core team
May 14 08:39:40 wyatt kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000000
May 14 08:39:40 wyatt kernel:  printing eip:
May 14 08:39:40 wyatt kernel: 0216c0bf
May 14 08:39:40 wyatt kernel: *pde = 00000000
May 14 08:39:40 wyatt kernel: Oops: 0000 [#1]
May 14 08:39:40 wyatt kernel: CPU:    0
May 14 08:39:40 wyatt kernel: EIP:    0060:[<0216c0bf>]    Not tainted
May 14 08:39:40 wyatt kernel: EFLAGS: 00010286   (2.6.5-1.358)
May 14 08:39:40 wyatt kernel: EIP is at object_path_length+0x10/0x25
May 14 08:39:40 wyatt kernel: eax: 00000000   ebx: 00000001   ecx:
ffffffff   edx: 2285a6a4
May 14 08:39:40 wyatt kernel: esi: 00000000   edi: 00000000   ebp:
00000003   esp: 1779fe00
May 14 08:39:40 wyatt kernel: ds: 007b   es: 007b   ss: 0068
May 14 08:39:40 wyatt kernel: Process ip (pid: 2995,
threadinfo=1779f000 task=174a3930)
May 14 08:39:40 wyatt kernel: Stack: 022db0e0 022db080 0216c145
022dad28 1651fc80 022a8be7 2285a6a4 022db0e0
May 14 08:39:40 wyatt kernel:        19defc10 022db080 00000000
021d9e0b 19def710 022db120 19def754 19defc10
May 14 08:39:40 wyatt kernel:        021db8ae 2285a680 14e58228
1779fe74 022c9d44 0212e95c 00000005 1779fec3
May 14 08:39:40 wyatt kernel: Call Trace:
May 14 08:39:40 wyatt kernel:  [<0216c145>] sysfs_create_link+0x28/0x117
May 14 08:39:40 wyatt kernel:  [<021d9e0b>] class_device_add+0xd7/0xfb
May 14 08:39:40 wyatt kernel:  [<021db8ae>]
fw_register_class_device+0xe5/0x120
May 14 08:39:40 wyatt kernel:  [<0212e95c>] buffered_rmqueue+0x124/0x147
May 14 08:39:40 wyatt kernel:  [<021db907>]
fw_setup_class_device+0x1e/0x90
May 14 08:39:40 wyatt kernel:  [<021db9e1>] request_firmware+0x68/0x139
May 14 08:39:40 wyatt kernel:  [<228a5481>]
reset_atmel_card+0x105/0x535 [atmel]
May 14 08:39:40 wyatt kernel:  [<228a2503>] atmel_open+0xb6/0x178 [atmel]
May 14 08:39:40 wyatt kernel:  [<02235a97>] dev_open+0x5f/0xcc
May 14 08:39:40 wyatt kernel:  [<022369cc>] dev_change_flags+0x48/0xee
May 14 08:39:40 wyatt kernel:  [<02267a19>] devinet_ioctl+0x255/0x4a1
May 14 08:39:40 wyatt kernel:  [<022694a8>] inet_ioctl+0x47/0x73
May 14 08:39:40 wyatt kernel:  [<022301a5>] sock_ioctl+0x268/0x280
May 14 08:39:40 wyatt kernel:  [<0223054f>] sys_socket+0x2a/0x3d
May 14 08:39:40 wyatt kernel:  [<0214ea0e>] sys_ioctl+0x1f2/0x224
May 14 08:39:40 wyatt kernel:
May 14 08:39:40 wyatt kernel: Code: f2 ae f7 d1 49 8b 52 24 8d 5c 19
01 85 d2 75 e9 89 d8 5b 5f
Comment 1 Tim Jackson 2004-05-24 21:40:00 EDT
Confirmed on FC2 final, not present in FC2 Test 3. Downgrading to
kernel build 327 stops the oops. See also bug #123918.
Comment 2 Bastien Nocera 2004-05-25 05:15:40 EDT

*** This bug has been marked as a duplicate of 123918 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:03:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.