Bug 1232399 - [GTK3] scrollbar can't be grabbed at the very screen edge
[GTK3] scrollbar can't be grabbed at the very screen edge
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
: 1244427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-16 12:15 EDT by Kamil Páral
Modified: 2015-11-12 03:18 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 03:18:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2015-06-16 12:15:52 EDT
Description of problem:
In Fedora 21 I can easily throw the mouse cursor against the right screen edge and grab the scrollbar of a maximized Firefox. But in Fedora 22, this is not possible, the scrollbar does not 'extend' to the very edge. Instead, I need to move the cursor 1 px from the edge in order to grab the scrollbar. It seems there's a 1 px border between the scrollbar widget and the screen edge that acts like a blind spot.

The end result is that with GTK3 Firefox you can no longer easily grab the scrollbar without thinking, just by going to the very right and clicking on it, but you need to be more precise and looking at the cursor position. Which is, of course, not optimal.

Version-Release number of selected component (if applicable):
firefox-38.0.5-2.fc22.x86_64
gtk3-3.16.3-1.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1. maximize firefox, open a long page showing scrollbar
2. mouse the cursor to the very right, touching the screen edge
3. click to grab the scrollbar, nothing happens
4. move the cursor 1px to the left, click to grab the scrollbar, it works now
Comment 1 Philip Heron 2015-06-22 19:08:20 EDT
It seems to be limited to Firefox. Everything else I have tried I can scroll as normal from the edge, including Thunderbird.
Comment 2 Robin A. Meade 2015-06-26 14:43:40 EDT
I'm using the NoiaScrollbars AddOn as a workaround:
https://addons.mozilla.org/en-US/firefox/addon/noiascrollbars/
Comment 3 Tim Niemueller 2015-09-03 08:39:56 EDT
*** Bug 1244427 has been marked as a duplicate of this bug. ***
Comment 4 Tim Niemueller 2015-09-03 08:41:24 EDT
This is really annoying, especially when using a trackpointer and not a mouse. Can the maintainers do something about this, please?
Comment 5 Tim Niemueller 2015-09-03 09:01:47 EDT
Thanks to https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/125734/comments/18 I found this workaround:

Create a file ~/.mozilla/firefox/<your profile>/chrome/userChrome.css and add:

hbox#browser { margin-right: -1px !important; }


Works fine for me and Firefox is finally usable again. So I guess someone messed up the Firefox default theme. That should be a reasonably easy fix, shouldn't it?
Comment 6 Robin A. Meade 2015-09-03 19:56:51 EDT
I confirm that the userChrome.css workaround worked in my case as well. Thanks Tim!
Comment 7 Jan Horak 2015-09-17 09:16:34 EDT
Upstream bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1205643
Comment 8 Jan Horak 2015-11-12 03:18:34 EST
We'll track it upstream.

Note You need to log in before you can comment on or make changes to this bug.