Bug 1232485 - Network interface configuration should be parameterized
Summary: Network interface configuration should be parameterized
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: Director
Assignee: Tomas Sedovic
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-16 21:04 UTC by Dan Sneddon
Modified: 2015-08-05 13:54 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-12.el7ost
Doc Type: Enhancement
Doc Text:
This enhancement add VLAN identifiers and OVS bond options to Heat templates. This reduces the amount of duplicate configuration. The Heat templates now contain the following parameters: BondInterfaceOvsOptions, StorageNetworkVlanID, StorageMgmtNetworkVlanID, InternalApiNetworkVlanID, TenantNetworkVlanID, ExternalNetworkVlanID,
Clone Of:
Environment:
Last Closed: 2015-08-05 13:54:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 189827 None None None Never
OpenStack gerrit 189835 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-06-16 21:04:34 UTC
Description of problem:
The network interface configurations share a lot of data that could be parameterized. For instance, the VLAN identifiers and the OVS bond parameters.

Version-Release number of selected component (if applicable):
All versions prior to poodles built on June 16, 2015.

How reproducible:
100%

Steps to Reproduce:
1. Deploy undercloud
2. Set up isolated networking
3.

Actual results:
In /usr/share/openstack-tripleo-heat-templates/, the configuration templates inside network/config/bond-with-vlans and network/config/single-nic-vlans are unwieldy, the same data gets put into 5 different files.

Expected results:
You should be able to set the OVS Bond Options and the VLAN identifiers at a global level in the Heat templates.

Additional info:
The latest poodle should have templates that have the line:
ovs_options: {get_param: BondInterfaceOvsOptions}

as well as several lines that look like this:
vlan_id: {get_param: InternalApiNetworkVlanID}

Comment 5 Ofer Blaut 2015-07-08 14:29:57 UTC
openstack-tripleo-heat-templates-0.8.6-23.el7ost.noarch

bond and vlans are created 

tested on computes and controller 

[root@overcloud-controller-1 heat-admin]# ifconfig
bond1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::3c22:f3ff:fe4f:6266  prefixlen 64  scopeid 0x20<link>
        ether 3e:22:f3:4f:62:66  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::b8a4:4bff:feac:964f  prefixlen 64  scopeid 0x20<link>
        ether 00:9c:02:b0:7f:e0  txqueuelen 0  (Ethernet)
        RX packets 194500  bytes 21045639 (20.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 516  bytes 44336 (43.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-int: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::c4e0:67ff:fe48:949  prefixlen 64  scopeid 0x20<link>
        ether c6:e0:67:48:09:49  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-tun: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::582c:5bff:febe:a740  prefixlen 64  scopeid 0x20<link>
        ether 5a:2c:5b:be:a7:40  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:9c:02:b0:7f:e0  txqueuelen 1000  (Ethernet)
        RX packets 8476536  bytes 1006642685 (960.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8316092  bytes 929805685 (886.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 44:1e:a1:73:39:90  txqueuelen 1000  (Ethernet)
        RX packets 163160  bytes 18743094 (17.8 MiB)
        RX errors 0  dropped 36723  overruns 0  frame 0
        TX packets 16  bytes 2060 (2.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfbe60000-fbe7ffff  

eth2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:9c:02:b0:7f:e4  txqueuelen 1000  (Ethernet)
        RX packets 9696440  bytes 1082714313 (1.0 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8394504  bytes 939129936 (895.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.0.2.8  netmask 255.255.255.0  broadcast 192.0.2.255
        inet6 fe80::461e:a1ff:fe73:3991  prefixlen 64  scopeid 0x20<link>
        ether 44:1e:a1:73:39:91  txqueuelen 1000  (Ethernet)
        RX packets 4029798  bytes 1315196333 (1.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4104767  bytes 599091310 (571.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfbee0000-fbefffff  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 5375491  bytes 555373535 (529.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5375491  bytes 555373535 (529.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vlan189: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.16.0.13  netmask 255.255.255.0  broadcast 172.16.0.255
        inet6 fe80::48c5:96ff:fe45:9de3  prefixlen 64  scopeid 0x20<link>
        ether 4a:c5:96:45:9d:e3  txqueuelen 0  (Ethernet)
        RX packets 3853  bytes 280006 (273.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 25  bytes 1530 (1.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vlan195: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.35.180.12  netmask 255.255.255.0  broadcast 10.35.180.255
        inet6 fe80::680b:89ff:fe8b:5197  prefixlen 64  scopeid 0x20<link>
        ether 6a:0b:89:8b:51:97  txqueuelen 0  (Ethernet)
        RX packets 22596  bytes 2488329 (2.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22271  bytes 2238204 (2.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vlan201: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.17.0.13  netmask 255.255.255.0  broadcast 172.17.0.255
        inet6 fe80::7848:ceff:fe97:80b9  prefixlen 64  scopeid 0x20<link>
        ether 7a:48:ce:97:80:b9  txqueuelen 0  (Ethernet)
        RX packets 15315154  bytes 1757609276 (1.6 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 15223146  bytes 1594287174 (1.4 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vlan202: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.18.0.13  netmask 255.255.255.0  broadcast 172.18.0.255
        inet6 fe80::2c02:bdff:fecb:673d  prefixlen 64  scopeid 0x20<link>
        ether 2e:02:bd:cb:67:3d  txqueuelen 0  (Ethernet)
        RX packets 1246941  bytes 214510957 (204.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1230648  bytes 203677083 (194.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vlan203: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.19.0.13  netmask 255.255.255.0  broadcast 172.19.0.255
        inet6 fe80::20d8:dcff:fed6:44fd  prefixlen 64  scopeid 0x20<link>
        ether 22:d8:dc:d6:44:fd  txqueuelen 0  (Ethernet)
        RX packets 37591  bytes 5385689 (5.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 38467  bytes 34709430 (33.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Comment 7 errata-xmlrpc 2015-08-05 13:54:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.