Bug 1232558 - Add SMBIOS 3.0.0 support to dmidecode
Summary: Add SMBIOS 3.0.0 support to dmidecode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dmidecode
Version: 6.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Oros
QA Contact: Mike Gahagan
Jana Heves
URL:
Whiteboard:
: 1249888 (view as bug list)
Depends On: 1232557
Blocks: 1205755 1247354 1270638 1274135
TreeView+ depends on / blocked
 
Reported: 2015-06-17 02:51 UTC by Xiaoqing Wei
Modified: 2016-08-19 14:38 UTC (History)
8 users (show)

Fixed In Version: dmidecode-2.12-7.el6
Doc Type: Release Note
Doc Text:
dmidecode now supports SMBIOS 3.0.0 This update adds SMBIOS 3.0.0 support to the *dmidecode* utility. Now, *dmidecode* can work with 64-bit structures according to SMBIOS 3.0.0 specification.
Clone Of: 1232153
Environment:
Last Closed: 2016-05-11 00:54:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1368489 'unspecified' 'CLOSED' 'dmidecode 2.12 does not support SMBIOS 3.0' 2019-12-04 17:31:34 UTC
Red Hat Product Errata RHEA-2016:0937 normal SHIPPED_LIVE dmidecode enhancement update 2016-05-10 22:54:50 UTC

Internal Links: 1368489

Comment 1 Xiaoqing Wei 2015-06-17 02:56:52 UTC
The corresponding kernel part
Bug 1232557 - [6.7 FEAT] SMBIOS 3.0 update

Comment 8 huhuang 2016-02-10 14:08:13 UTC
*** Bug 1249888 has been marked as a duplicate of this bug. ***

Comment 9 Mike Gahagan 2016-04-08 19:04:50 UTC
I couldn't find any systems with SMBIOS 3 which could run RHEL 6, however dmidecode-2.12-7.el6 will install and run on a RHEL 7 system and I was able to verify it works with SMBIOS 3 on a RHEL 7 system.

Comment 10 sean.chenfei 2016-04-28 01:45:45 UTC
(In reply to Mike Gahagan from comment #9)
> I couldn't find any systems with SMBIOS 3 which could run RHEL 6, however
> dmidecode-2.12-7.el6 will install and run on a RHEL 7 system and I was able
> to verify it works with SMBIOS 3 on a RHEL 7 system.

The package have been downloaded to my computer, however a smbios 3.0 machine need to be a 32-socket server which is busy doing other test. I will find a time slot to do test the new dmidecode rpm.

Comment 12 errata-xmlrpc 2016-05-11 00:54:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0937.html


Note You need to log in before you can comment on or make changes to this bug.