Bug 1232570 - Qcow2 preallocation options Falloc, full missing in RHEL7.1 qemu-kvm-rhev
Summary: Qcow2 preallocation options Falloc, full missing in RHEL7.1 qemu-kvm-rhev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: pre-dev-freeze
: 7.2
Assignee: Max Reitz
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 04:56 UTC by Pradeep Kumar Surisetty
Modified: 2015-12-04 16:47 UTC (History)
11 users (show)

Fixed In Version: 2.3.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Pradeep Kumar Surisetty 2015-06-17 04:56:17 UTC
Description of problem:

With RHEL7,1 qemu-kvm : Qcow2 image creation supports preallocation=off, metadata, falloc, full. 


With rhel7.1 qemu-kvm-rhev:  Qcow2 image creation supports only preallocation=off, metada.  falloc, full options are missing.


Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.1.2-23.el7_1.3.x86_64

How reproducible:


Steps to Reproduce:
1.check qemu-img man page. Or create image using metadata or falloc

Image creation with different options: 
----------

Preallocation=off

 qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=off 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='off' lazy_refcounts=off 

preallocation=metadata:

qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=metadata 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='metadata' lazy_refcounts=off 

Preallocation=falloc:

 qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=falloc 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='falloc' lazy_refcounts=off 

qemu-img: /tmp/test.qcow2: Invalid preallocation mode: 'falloc'

Preallocation=full

 qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=full 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='full' lazy_refcounts=off 
qemu-img: /tmp/test.qcow2: Invalid preallocation mode: 'full'

---


Actual results:

image creation fails with these options.  

Expected results:

Should be able to create qcow2 image with preallocate=falloc, full options.

Comment 7 Qian Guo 2015-07-01 07:51:23 UTC
Reproduced with qemu-kvm-rhev-2.1.2-23.el7.x86_64

#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=off 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='off' lazy_refcounts=off 
# qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=metadata 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='metadata' lazy_refcounts=off 
#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=falloc 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='falloc' lazy_refcounts=off 
qemu-img: /tmp/test.qcow2: Invalid preallocation mode: 'falloc'
#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=full 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='full' lazy_refcounts=off 
qemu-img: /tmp/test.qcow2: Invalid preallocation mode: 'full'


Can not create img by "full", "falloc" preallocateion mode, so this bug is reproduced.

Verified with qemu-kvm-rhev-2.3.0-6.el7.x86_64
#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=off 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='off' lazy_refcounts=off refcount_bits=16
# qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=metadata 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='metadata' lazy_refcounts=off refcount_bits=16
#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=falloc 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='falloc' lazy_refcounts=off refcount_bits=16
#  qemu-img create -f qcow2 /tmp/test.qcow2 -o preallocation=full 1G
Formatting '/tmp/test.qcow2', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 preallocation='full' lazy_refcounts=off refcount_bits=16

So this bug is fixed.

Comment 12 errata-xmlrpc 2015-12-04 16:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.