Bug 1232589 - [Bitrot] Gluster v set <volname> bitrot enable command succeeds , which is not supported to enable bitrot
Summary: [Bitrot] Gluster v set <volname> bitrot enable command succeeds , which is no...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1228135 1229134
Blocks: 1223636
TreeView+ depends on / blocked
 
Reported: 2015-06-17 06:33 UTC by Gaurav Kumar Garg
Modified: 2016-06-05 23:38 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1229134
Environment:
Last Closed: 2015-06-20 09:51:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-17 06:34:29 UTC
REVIEW: http://review.gluster.org/11265 (bitrot/glusterd: gluster volume set command for bitrot should not supported) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Anand Avati 2015-06-18 06:53:14 UTC
COMMIT: http://review.gluster.org/11265 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit a99d935a876851efa25fad5f48889fd9d2a59f68
Author: Gaurav Kumar Garg <ggarg@redhat.com>
Date:   Mon Jun 8 13:01:44 2015 +0530

    bitrot/glusterd: gluster volume set command for bitrot should not supported
    
    Currently gluster volume set <VOLNAME> bitrot succeeds. gluster volume
    set command for bitrot is not supported.
    Gluster should only accept gluster volume bitrot <VOLNAME> * commands.
    
    Change-Id: I5ff4b79f202ad018c76188f19d6311aad0d7c166
    BUG: 1232589
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/11118
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    (cherry picked from commit 1ac3d28d8dde6360550c80a10d8add572937be16)
    Reviewed-on: http://review.gluster.org/11265

Comment 3 Niels de Vos 2015-06-20 09:51:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.2, please reopen this bug report.

glusterfs-3.7.2 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2015-June/000006.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.