Bug 1232612 - Disperse volume: misleading unsuccessful message with heal and heal full
Summary: Disperse volume: misleading unsuccessful message with heal and heal full
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1203089
Blocks: qe_tracker_everglades
TreeView+ depends on / blocked
 
Reported: 2015-06-17 07:28 UTC by Ashish Pandey
Modified: 2015-07-30 09:48 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 1203089
Environment:
Last Closed: 2015-07-30 09:48:19 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-17 07:35:13 UTC
REVIEW: http://review.gluster.org/11269 ( ec: Display correct message after successful heal start) posted (#1) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)

Comment 2 Anand Avati 2015-06-23 06:09:26 UTC
COMMIT: http://review.gluster.org/11269 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d88c3b6ee390b1780bda30b1aff6e02d558fd6c7
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Wed Jun 17 12:40:06 2015 +0530

     ec: Display correct message after successful heal start
    
     Problem : While launching heal, it shows heal launch
     was unsuccessful. However, internaly it was successfully
     launched.
    
     Solution : Don't reset op_ret to -1 in for loop for
     every brick.
    
    Change-Id: Iff89fdaf6082767ed67523a56430a9e83e6984d3
    BUG: 1232612
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/11269
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 3 Kaushal 2015-07-30 09:48:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.3, please open a new bug report.

glusterfs-3.7.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12078
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.