Bug 1232650 - dovecot FTBFS on s390(x) and ppc64
Summary: dovecot FTBFS on s390(x) and ppc64
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2015-06-17 08:58 UTC by Jakub Čajka
Modified: 2015-09-01 23:22 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-09-01 23:22:50 UTC


Attachments (Terms of Use)
Proposed fix (592 bytes, patch)
2015-06-17 08:58 UTC, Jakub Čajka
no flags Details | Diff

Description Jakub Čajka 2015-06-17 08:58:31 UTC
Created attachment 1039814 [details]
Proposed fix

Description of problem:
dovecot fails to build due to test failure.
.
.
.
net_is_in_network() .................................................. : ok
test-net.c:59: Assert failed: net_addr2ip("127.0.0.1", &ip) == 0 && ip.family == AF_INET && ip.u.ip4.s_addr == (127 | (1 << 24))
net_ip2addr() ........................................................ : FAILED
test: random seed #1 was 1433227365
numpack (good) ....................................................... : ok
.
.
.



Version-Release number of selected component (if applicable):
dovecot-2.2.18-2.fc20
dovecot-2.2.18-2.fc21
dovecot-2.2.18-2.fc22
dovecot-2.2.18-2.fc23


How reproducible:
Always

Steps to Reproduce:
1. build package on s390(x), ppc64

Actual results:
build fails
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=308866
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=309422
http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=316615
http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=317126
http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=321213

Expected results:
build passes

Additional info:
It seems as bug in test suit as test is expecting IPv4 address in LE format (0x0100007f), but it gets address in BE format(0x7f000001). Patch in attachment should fix this issue. Please fix it in all branches.

Thanks Jakub

Scratch builds with patch:
http://koji.fedoraproject.org/koji/taskinfo?taskID=10092460
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1843558
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2550313
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3038039

Comment 1 Rafael Fonseca 2015-08-13 12:43:14 UTC
Any updates on this? Has the patch been proposed upstream?

Comment 2 Rafael Fonseca 2015-08-17 13:52:13 UTC
Looks like the patch was applied upstream:

changeset:   18892:b268e186d029
user:        Timo Sirainen <tss@iki.fi>
date:        Mon Jun 29 13:36:38 2015 +0300
summary:     lib: Fixed unit test with big-endian CPUs.

and there is a patch downstream for this ('dovecot-2.2.18-fixbuild.patch') included in dovecot-2.2.18-3.

Can we close this bug?

Comment 3 Fedora Update System 2015-08-17 13:58:21 UTC
dovecot-2.2.18-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dovecot-2.2.18-3.fc22

Comment 4 Fedora Update System 2015-08-19 07:56:49 UTC
Package dovecot-2.2.18-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dovecot-2.2.18-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13631/dovecot-2.2.18-3.fc22
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-09-01 23:22:49 UTC
dovecot-2.2.18-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.