Bug 1232658 - Change default values of allow-insecure and bind-insecure [NEEDINFO]
Summary: Change default values of allow-insecure and bind-insecure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1181466 1232660
TreeView+ depends on / blocked
 
Reported: 2015-06-17 09:07 UTC by Pranith Kumar K
Modified: 2016-06-16 13:12 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1232660 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:12:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
ylavi: needinfo? (aavati)


Attachments (Terms of Use)

Description Pranith Kumar K 2015-06-17 09:07:05 UTC
Description of problem:
We are increasingly seeing that more people want these turned on.
So changing the defaults.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-06-18 14:23:32 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#4) for review on master by Prasanna Kumar Kalever

Comment 2 Anand Avati 2015-06-18 14:37:12 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#5) for review on master by Prasanna Kumar Kalever

Comment 3 Anand Avati 2015-06-19 13:06:40 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#6) for review on master by Prasanna Kumar Kalever

Comment 4 Anand Avati 2015-06-24 10:54:39 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#8) for review on master by Prasanna Kumar Kalever

Comment 5 Anand Avati 2015-06-24 11:34:50 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#9) for review on master by Prasanna Kumar Kalever

Comment 6 Anand Avati 2015-06-29 06:24:24 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#10) for review on master by Prasanna Kumar Kalever

Comment 7 Anand Avati 2015-06-29 10:44:29 UTC
REVIEW: http://review.gluster.org/11039 (rpc: By default set allow-insecure, bind-insecure to on) posted (#11) for review on master by Prasanna Kumar Kalever

Comment 8 Yaniv Lavi 2015-07-16 03:52:31 UTC
should this be modified?

Comment 9 Prasanna Kumar Kalever 2015-07-22 10:00:32 UTC
There  were few problems discovered by http://review.gluster.org/11039 which can be addressed by http://review.gluster.org/#/c/11512/ (Waiting to get merged)

Comment 10 Niels de Vos 2016-06-16 13:12:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.