Bug 123267 - Example for filename tag is wrong
Example for filename tag is wrong
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
http://fedora.redhat.com/participate/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-14 23:06 EDT by Paul W. Frields
Modified: 2009-07-07 00:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 17:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix tags from "command" to "filename" (901 bytes, patch)
2004-05-14 23:09 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Paul W. Frields 2004-05-14 23:06:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The example given for the <filename> tag incorrectly uses the
<command> tag instead.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
1. View guide.
2. Quiver with confusion.    

Actual Results:  I was confused, but only for a moment. Thank goodness
Karsten and Tammy are there to steady us! :-)

Expected Results:  The example should use the tag it illustrates,
methinks.

Additional info:
Comment 1 Paul W. Frields 2004-05-14 23:09:27 EDT
Created attachment 100243 [details]
Patch to fix tags from "command" to "filename"

I'll be in Raleigh 5/16/04 - 5/21/04... would like to buy any FDP members a
tasty beverage of their choice if you're available.
Comment 2 Gregory Leblanc 2004-08-02 13:05:35 EDT
As long as things are getting changed in this section of the docs,
redhat-config-* should probably get replaced with system-config-*

Also, <filename> isn't the correct tag here, since we're not talking
about an actual file name.  Perhaps <application> is the best choice
here.  
Comment 3 Paul W. Frields 2004-08-02 13:34:09 EDT
Neither one is a 100% perfect fit. However, the Documentation Guide
explicitly states that <filename> should be used for RPM package
names; see
<http://fedora.redhat.com/participate/documentation-guide/s1-xml-tags-filename.html>
for more info. Since the package itself is not something that is
executable, that's a sensible choice to me, and I'm not in favor of
changing it.
Comment 4 Gregory Leblanc 2004-08-03 02:35:41 EDT
Ah, you were just trying to fix the inconsistency between the text
written and the actual markup used. 

I'm not in favor of using <filename> for rpm package names, because
package names are NOT file names.  This has actually bitten folks in
the past, though not Red Hat or Fedora, AFAIK (caused all kind of
confusion for SuSE users of old).  

Also, according to TDG, the application tag is for "The name of a
software program."  It also suggests that "The appelation
“application” is usually reserved for larger software packages."  I'd
say that in most cases, this applies directly to rpm package names. 
Perhaps a role attribute could help clarify this.  I'll try to poke
through the archives and see if anything has been discussed previously.
Comment 5 Tammy Fox 2004-08-12 17:11:11 EDT
Thanks. Your changes have been made in CVS (file version 1.7).
Comment 6 eric@christensenplace.us 2009-07-07 00:08:14 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.