Bug 1232693 - glusterd crashed when testing heal full on replaced disks
Summary: glusterd crashed when testing heal full on replaced disks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Satish Mohan
QA Contact:
URL:
Whiteboard: GlusterD
Depends On: 1231635 1233041
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-17 10:27 UTC by Anand Nekkunti
Modified: 2016-06-16 13:13 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1231635
Environment:
Last Closed: 2016-06-16 13:13:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-06-17 12:39:25 UTC
REVIEW: http://review.gluster.org/11276 (glusterd: Removing sync lock and unlock inside rcu read critical section) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)

Comment 2 Anand Avati 2015-06-18 06:51:28 UTC
REVIEW: http://review.gluster.org/11306 (glusterd: Removing sync lock and unlock inside rcu read critical section) posted (#1) for review on release-3.7 by Anand Nekkunti (anekkunt@redhat.com)

Comment 3 Anand Avati 2015-06-19 09:32:40 UTC
COMMIT: http://review.gluster.org/11276 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8ddf7f2669779cee460f1e008cdb62671cf15a40
Author: anand <anekkunt@redhat.com>
Date:   Wed Jun 17 16:11:48 2015 +0530

    glusterd: Removing sync lock and unlock inside rcu read critical section
    
    Issue : Glsuterd was crashing during peer probe.
    
    RCA :  In glusterd, we are using big lock which is implemented based on sync
    task frame work for thread synchronization, sync task frame work swap the threads
    if there is no worker pool threads available. Due to this rcu lock and rcu unlock
    was happening  in different threads (urcu-bp will not allow this), resulting into
    glusterd crash.
    
    fix : Removing sync lock and unlock inside rcu read critical section, which was left out by
    http://review.gluster.org/#/c/10285/ patch.
    
    Change-Id: Id358dfcc797335bcd3b491c3129017b2caa826eb
    BUG: 1232693
    Signed-off-by: anand <anekkunt@redhat.com>
    Reviewed-on: http://review.gluster.org/11276
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>

Comment 7 Niels de Vos 2016-06-16 13:13:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.